Mia MIDI i/o does not show up in jack. No sound i/o


I have a miaMidi PCI snd card w/ Ubuntu 8.04.1, & Ardour 2.5.

I use qjackctl interface… I use spdif i/o to my Yamaha 01v mixer… This all works in Windows XP (I do dual boot), but not in Ubuntu.

In the connect panel in Jack, in the audio frame, the i/o ports that appear in the above set up are, in the output side: alsa pcm, ardour, & system (my system is a sis chip integral on the motherboard, & I do not anywhere that I know, have it ‘turned on’ (?), so I do not, for the life of me, know why it shows here… as I do have my mia card turned on in the sound panel… & when I test it there, it works… I also use it frequently for audio cd’s, etc… which of course are not jack connected). On the input side, there is: ardour, & system.

My mid MIDI connection does, however show (not always in the midi tab, strangely, but always in the alsa tab).

I sure would appreciate any help available.

Thanks much,

Of course, in the last paragraph above, which reads:

"My mid MIDI connection does, however show (not always in the midi tab, strangely, but always in the alsa tab).’

I meant to say: “My mia MIDI connection…” etc.

Fingers get minds of their own, some times! :slight_smile:

you have 2 soundcards :
1- the onboard chip
2- the PCI card

you have to tell jack which card you want to use. In qjackctl, you can choose which hardware device you want to use (setup window). The alsa names are hw:0, hw:1, etc. In your case, I bet you must select hw:1 (hw:0 is the default and probably is you onboard chip. You can turn it off in the BIOS before kernel boot and ALSA won’t see it at all).

If you have the MIDI io in the alsa tab, it’s because you don’t start jack with its own MIDI stuff (another option in qjackctl but jack MIDI is still being developed). Instead, you use the ALSA layer (which is fine) so no need to worry about it.

If you don’t have any use of the onboard chip, turn it off in the BIOS and make sure your PCI card has its own IRQ, not sharing it with another device. Just check the file /proc/interrupts to spot which IRQ your PCI soundcard is assigned. If it shares its IRQ, then plug your card in another free PCI slot until you see it sitting alone with its own IRQ.

Hi Thorgal,

I appreciate your making the time to reply.

I turned off my onboard sound chip in the bios, as suggested. Didn’t check the irq, but as my audio/midi setup works in Windows, I’ll more or less assume there is no conflict there.

I did note, that upon booting up jack & ardour, there was a common error message:

    "/usr/local/bin/jackd: error while loading shared libraries: libjackserver.so.0: cannot open shared object file: No such file or directory"

Could this be (some) of the culprit? & if so (or even not) what can I do to get these ‘shared libraries’ in line & working?

& by the way, alsa saw my miamidi sound card as hw:0 & when it was turned on, the onboard sound chip as hw:1.

If you could point me toward a good (recommended) tutorial on setting up jack that might be helpful. I was rather used to OMS in the Mac world, which did most of what really needed doing with out much help from the ‘user.’ & I’m not complaining… just the fact (jack)!

Thanks again,

Ciao Henry,

Looks like you compiled jack yourself. Anything that ends up in /usr/local is usually the result of some custom compilation from the user.

I suggest the following :

1- make sure you uninstall any custom version of jackd if you had already compiled and installed your own. You don’t have to clean the source, just uninstall it

2- same for ardour if applicable

3- install or reinstall jackd and libraries from your package manager. Official version is 0.109.2 IIRC
4- same for ardour (2.5)
5- same for qjackctl (3.1 or 3.2)

No need to reboot if you PCI soundcard has already been detected during the last boot. Make sure it works : fire up the alsamixer from a terminal and see that things look OK (nothing muted, levels OK). I assume here that alsamixer is good enough a hardware mixer for your PCI card. Could be, depending on the chip, that envy24control is better a mixer for your card (e.g. all ice1712 based cards like M-Audio Delta serie, etc). Just make sure you have the alsa-tools or alsa-tools-gui, whatever they call the package nowadays.

Assuming that you can operate in realtime (which you can with a normal kernel, does not need to be fully preempted with Ingo Molnar’s RT patch, that’s for extreme RT operation, just make sure you have the right priviledges, granted by changing /etc/security/limits.conf where you can raise the process priority for the audio group, which you should belong to:

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -19


So you should now have all in hands : a working sound card and an environment which will be suitable for jack.

Before using qjackctl, let’s make sure jack works as expected. In a terminal, type :

jackd -R -P70 -dalsa -dhw:0 -r48000 -p1024 -n2

I assume here that you soundcard is already set up to 48kHz. Of course, if you want to operate at different sample rate (44.1 or 96) you have to modify your soundcard setup and launch jack with the right SR.

jack options
-R: operate in realtime mode
-P70: jackd priority level (not the same as audio processes)
-dalsa: use jack-alsa backend, so jackd talks to the alsa layer behind the stage
-dhw:0 : use hw:0 alsa device (if your PCI card is the only alsa device detected, that’s OK)
-r48000: operate jackd at 48kHz sample rate
-p1024: number of frames per period,
-n2: the number of periods, so buffer is 2x1024=2048

That’s the most basic jack setting in realtime mode. If everything works, you should get something like that in the terminal :

jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver …
apparent rate = 48000
creating alsa driver … hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit little-endian
ALSA: use 2 periods for playback

I have a dedicated linux DAW but sometimes I use my laptop to quickly check things. The soundchip is an intel ICH4 (not the most recent HDA stuff) and I have a good performance with generic kernel, realtime mode and the previous jack setting except I set n=3 instead (3 periods).

OK, if you get that far, in another terminal, launch ardour2 :


Then you should be in business.

I had a Mia (not the MIDI version), and I had to compile the ‘drivers’ myself…I will look and see if I can find the page that had the step by step…it is not included in ubuntu’s audio system by default.

Hi muzicman0,

My problem is not with my MiaMidi card, I am reasonably sure… I got my drivers & firmware pretty well set up. My problem, I think, is with jackd & possibly qjackctl.

The jack server will not start up… (with qjackctl). I have tried uninstalling (apt-get purge ) & reinstalling.

I did have a lot of problems, after first installing Ubuntu, getting my Echo sound card set up in Ubuntu… I finally found the author of the drivers… & he got me directed in a helpful way (& I really solved the problem by also finding & installing the appropriate firmware).

I may be wrong or off base, but I have to work at getting a clean install of jackd, etc., which, for some reason, I am not doing. Each time I reinstall it, the configuration is set up as before (though the ‘purge’ makes claims that it is purging my configuration files). I have tried this a bunch of different ways, & think perhaps, that jackd is installed somewhere in a non-standard place (???).

Part of the problem, for some reason, I discovered (Thorgal’s suggestion to uninstall, etc.) that ‘jackd’ was not even installed… (it must have gotten zapped some how). Any way, I did a re-installation & actually had sound coming out (after some parameter fiddling). That was yesterday… This morning, I went to start Ardour/jack up, & lo & behold, jackd is nowhere to be found…

I am not sure what Thorgal means re:

    "make sure you uninstall any custom version of jackd if you had already compiled and installed your own. You don’t have to clean the source, just uninstall it"

I am not knowledgeable enough regarding linux/Ubuntu to understand what a ‘custom version’ is. I simply built qjackctl, ardour 2.5 (which is not in my package manager repositories, as is the most recent version of 'qjackctl, which I know not, now, how to uninstall! I did not direct the location, so I am not even sure where the program is even really located? & which I wish to do, so that I may start this installation again, clean start).

I tried reinstalling jackd again via the package manager, but qjackctl/jackd will does not & will not start up (this is to say, qjackctl shows up… but for nothing).

Any suggestions out of this quandary will be appreciated.

Thanks again.

Sorry, it took a little longer to get this up, but try:


read through the entire thread…page 4 is the spot that made it work for me if I recall…

hope this helps!


What your soundcard?

My regards