Memory Lock Message


I’m using mixbus/ardour and continue to get the memory lock message at session startup. I’ve tried the suggestions I’ve found such as adding @audio - memlock unlimited to limts.conf and then adding myself to audio group - memory message continues. I’m using fedora 24. I can’t seem to get ulimit -l to out put unlimited. I’ve tried sudo -i ulimit -l unlimted, but ulimit -l continues to output 64. Any ideas or suggestions is appreciated.


Did you logout and then log back in? those changes never take effect with a new login.

Yes. But I did more digging and found a suggestion to create a 99-realtime.conf in /etc/security/limits.d and then create a realtime group, adding user to the new group. I left @audio lines in limits.conf as well. Now I’m not getting the memory lock message but ulimit -l still outputs 64. I’m not sure if all is set correctly. Unless I unknowingly clicked the “don’t show message again” box, I’m assuming the memory is unlocked for Ardour? Had 2 xruns after about 10 minutes of playing - but I was getting hundreds priot to setting a 99-realtime.conf.