Memory limits on OpenSUSE

I have the Ardour 4.2 and am using OpenSUSE 13.2 and I don’t know how to take out the memory limits (the “ulimit -l” warning). I’ve searched a lot and still not solved anything.
I have a limiter on master and a compressor on the audio track, when I set it to Peak, it slows down the system. I have put my CPU on performance and it still slows down. The plug-ins are the CALF ones.

My laptop:
CPU: T7200 (2Ghz 4MB cache)
RAM: 3GB PC5300
HD: WD Scorpio Blue
VGA: Intel 945GM

Start a terminal
Become root : su -
Create a group called ardour (for instance) : groupadd ardour
Add your user to that group : usermod -a -G ardour your-username
Edit /etc/security/limits.conf and add the following :

@ardour - memlock unlimited

Optional for running jack with real-time priority :

@ardour - rtprio 99

Log out and in again and the warning should disappear.
Note that “unlimited” could pose a potential risk if one of your processes for some reason starts hogging memory. Replacing it with half of your RAM (1500000) or something should be a bit safer and shouldn’t affect Ardour’s performance.

If I do this for Mixbus should limits.conf say (with respective groupadd command):
@mixbus - memlock unlimited
@ardour - …

also, does it need to say ardour4, mixbus3, etc?

the group name is not significant. Its helpful to have it a meaningful label, but as long as you are a member of the group it could be called mashedpotatoes and work fine.

I see. Thanks for the explanation.