MCU touch mode does not work


I have a Macke Control Universal, connected to a Midisport 4x4.

Because my mackie is connected to a multiports midi device, the /dev/snd/midiXXXX trick in ardour.rc did not work.
So I simply route [control], [mcu] and [seq] to my midi port in both directions using jack.

The result is :

  • very buggy transport controls (I have to press a button 4-5 times before it works)
  • no timecode display (I also tried with the logic mode)
    And the biggest problem for me :
  • no fader touch sensitivity!

In write mode, I can make an automation, but touch mode just never overwrites anything.
It’s a big problem, I cannot make an automation without this.

Thanks in advance for your help!

arf, ok I understand.
So you think the touch mode works in ardour 3 for sure?
THANKS! :slight_smile:

PS: paul, where are you located?

Yes the Mackie code in A2 is a bit obscure. I can dig in and try to find a reason why TOUCH won’t work(It certainly used to), but to be honest I haven’t touched my Mackie in a while for mixing sadly so I haven’t paid much attention to the state of Mackie code on A2 lately.


@MisterBark: yes, it definitely all works in A3. We’ve tested with a Mackie Control Pro, SSL Nucleus, Steinberg CMC surfaces, Behringer devices in Logic Mode, and even a Zoom R8. I live and work on the edge of Philadelphia, PA.

Great, thanks!

I assume this is Ardour v2?

  1. Only route the MCU port. The others are for completely different things and likely only to cause problems with A2’s code

  2. You almost certainly HAVE to do the ardour.rc edit. Otherwise you are likely using the alsa-seq which is known to cause problems. Why you feel you can’t do this is probably best handled on IRC, I won’t be around for another week but maybe someone else there can help you.


ardour 2.8.12
(built from revision 10144)

  1. You’re right. I just did and everything is the same.

  2. How can I define a midi device for mcu in ardour.rc since my mcu is connected only to a particular port of that device?

I have connected my mcu to another soundcard that has only 1 in/out midi.
Then I was able to use the rc file(s) and let ardour control jack.

But, the only problem it has fixed is the buggy transport controls.
Touch is still not detected! and there is no timecode display (don’t care that much about that)

I tried both Macke and Logic modes.

@MisterBark: at this point, i’m afraid to say that I’m not willing to stand behind the Mackie Control support in Ardour 2.X. I rewrote it almost entirely from scratch for Ardour 3, and have tested it extensively with a variety of different MC-supporting devices. It may be that other people want to offer some thoughts on the Ardour2 setup, but not me.

Hi MisterBark,
Did you get your Mackie Control Universal “touch” feature to work for you? I’m thinking of buying one just to get the “touch” feature, which is not available with my BCF2000.