maximum amount of locked memory

Hello all

When I run Ardour I get the following message:

WARNING: Your system has a limit for maximum amount of locked memory. This might cause Ardour to rum out of memory before your system runs out of memory.

You can view the memory limit with ‘ulimit -l’, and it is normally controlled by /etc/security/limits.conf

I’ve looked for an answer to this but could only find info on the subject and not a fix. I’ve installed Ubuntu Studio with the following kernel.

uname -r
uname -a
Linux meditor 2.6.22-14-rt #1 SMP PREEMPT RT Tue Feb 12 09:57:10 UTC 2008 i686 GNU/Linux

Is it possible to set the limit.conf file to unlimited as far as the memory goes? If so, what is the setting for that?

Thanks for the help.

“unlimited”. amazing, eh?

Edit your /etc/security/limits.conf file by typing on the terminal (as root) # gedit /etc/security/limits.conf . (Probably kedit instead of gedit, anyway your favourite text editor). You’ll see near the end of the file @audio memlock - wathever number. Change that line to @audio memlock - unlimited. Check with $ ulimit -l.

Make sure you (as a user) are in the audio group. Type (as user) $ groups yourusername.


These are my @audio lines in /etc/security/limits.conf (64studio)

@audio - rtprio 99
#@audio - memlock 250000
@audio - nice -10

So just commenting out that line works too

Pablo Fernández, thank you for replying. I did what you said and still got the same error. I then googled “how to change ulimit -l” and found the following link.

The info in the link worked for me if I run Ardour as root which more of a pain then anything, but it works without mem errors. I also made my limits.conf file the same as yours and ran “$ groups username” and got the following results -

groups johnswb
johnswb : johnswb adm dialout cdrom floppy audio dip video plugdev scanner lpadmin admin netdev powerdev

I am currently running Ubuntu Studio 7.10, I just downloaded 64studio and thinking about giving it a try. Are you happy with 64studio?

Yes I am!
I thought that would solve your issue but it must be more to it, I don’t know. I’m sorry I can’t help you.
I’ve never tried Ubuntu Studio but I don’t think it is a bad choice. Anyway, if you want a distro mainly for making music I suggest you should try 64studio. It’s very stable and you don’t have to tweak it very much. Just follow the FAQS and search in the forums or ask there if you have difficulties.

I’m not sure what changed but today all is good… side note: I just ordered an Akai MPD32 to go along with my Ensonq ASR-10 and now Ardour. My next step is to get all three working together. If I’m un-successful I will reinstall with 64studio. Does 64studio work well with video editing? I’m in to making beats and putting them to video.

PS. you did help me no need to say sorry…

note that most changes to a user or group’s capabilities require the affected user to logout and back in to take effect. this is probably why it inexplicably started working.