Matching sample sample rate to project sample rate

Hi there! New to Ubuntu and Ardour. I’m usually a Logic Pro X user. I’ve taken a liking to the Linux OS, however. Now, I am beginning my project at the sample rate of 96 hz and I’m inserting a sample that might be 48 or 44.1. When I go to do this it notifies me that the track does not match the project sample rate and if I still want to import. Obviously the track then sounds a lil weird. I don’t have this happen in Logic, Logic asks if I want to change the project or the audio… is there a way that Ardour also does this?

Thanks in advance. :slight_smile:

There are two methods of “bringing in” existing audio files to a session. One is called “importing”, and that will automatically resample any file(s) you choose. The other is called “embedding”, and just uses the files as they are.

This is controlled by the “Copy files to session” checkbox in the import dialog.

If you have disabled this, then you are “embedding”, not “importing”, and Ardour will not resample these files. The warning you mentioned only shows up when embedding, so I suspect you unchecked this box at some point.

Bet, will check on that. Thank you :slight_smile:

I think I got it confused with LMMS. That worked thank you!!! :slight_smile: