Master playback gets recorded by Audio input

Hi

I have a few midi tracks and an audio input track, and finally I’m trying to record microphone audio. I’ve added an(other) Audio track, and select 1 as the input. Now, if I mute everything else and record I am able to record the audio from the microphone. However, if I unmute any of the other tracks while recording from this “Mic” Audio track, whatever’s on those tracks get recorded too! Why is this happening, and how can I prevent it?

Simen

Are you absolutely sure it is being recorded and not just playing back as you record your new track? If you mute everything but the new track after recording with the microphone do you still hear other audio? Under default conditions, adding a new audio track with microphone input will record only that but you will hear what is previously recorded on other tracks (necessary most of the time, of course, for alignment purposes).

Yes I am certain my microphone input gets recorded, and is fine if I mute all the other tracks.

On which system and which soundcard do you use?

Some PC built-in soundcards (notably HDA Intel) have a hardware mixer option to loop back the output. This allows one to record what is sent to the speakers.

On GNU/Linux this shows up in alsamixer:

I tried with both JACK and ALSA on Linux, with a SoundBlaster Audigy card. Recording works quite fine in OBS studio.

I just tried it again now even with everything else muted, since its a compressor mic with no preamp it’s quite low, and if I put on an amplifier plugin loud enough for me to actually hear my voice it’s as if it gets echoed into something almost robotic sounding. So its like the master monitor gets recorded? It’s strange though because even if there’s nothing on the mic track already there’s a horrible echo in my speakers and that gets recorded. I’m not able to get an audio output on anything else like VLC or YouTube while Ardour is running so I’m not sure if its recording my whole system audio or just the Ardour master.

If I record it first without the amp so that I can barely hear it, but see it pick up on the channel signal level indicator, and apply the amp plugin after, then it sounds great. However, again if I try to record on the same track after the amp is on, horror ensues.

I can’t see a Loopback on the alsamixer options, please see the attached images: