Master Bus is bypassed after opening session in MixBus 3

Hi

I opened a session that I had saved in Version 3 in Mixbus 3 that I’ve recently purchased. I was just checking Mixbus out, but wanted to continue to record / edit in Ardour 3 or 4.

I don’t know whether Mixbus saved the session file, it must have, because now, I can open it in either Ardour 3 or 4, but all of the audio tracks are bypassed. Right clicking on the pan area, and unselecting ‘bypass’ then re-enables the track(s). However, the master bus also appears to be bypassed, since all the audio tracks are not connected to it and cannot be connected to it. In the selection area all of the tracks are ‘whited out’. Right clicking in the master track does not bring up an option to unbypass the master. So now, the session will play, the meters for each individual tracks move, but the master can’t be connected to either an input or output.

I tried a little editing of the session file, but my edited version would not open on Ardour, and now I am stumped. I seem to have gone down a one way road, where the only solution seems to import the audio files into a new session and redo all the plugins etc.

Any help to re-enable the master bus would be appreciated.

Thanks
Angus

OK

I managed to solve this problem. For some reason the master in ports were removed. The input button still showed, but I was unable to connect any busses or inputs to the master. Right clicking and add audio port to the master bus solved this problem. I did this twice, for L and R. Suddenly, the master then got a pan control, which was greyed out. Right clicking this then showed that ‘bypass’ was enabled. Unticking this box then got me my master back. Very relieved. Now I can get back to recording and mixing, instead of scratching my head wondering what happened.

-Angus.

Glad that you figured this out.

Mixbus does not use the Ardour Panners (they are bypassed when opening an Ardour session in Mixbus). Also Mixbus does not use the “standard” connections. Most (if not all) routing is internal to Mixbus.

Mixbus 3.0 is based on Ardour4.1 (and recent mixbus interim releases follow ardour-git), so don’t bother with Ardour3.

I’m curious though. If I may ask: What made you choose to go from Mixbus to Ardour?

I was always with Ardour. From I think version 2.4 I am happy with version 3. I wanted to upgrade to 4 so purchased 4.2 and Mixbus - and then maybe track to Ardour and mix in Mixbus, but what is holding me back is that the nice selection of plugins I have on Ardour 3 with nice guis have largely disappeared on Ardour 4 and Mixbus (Invada and a lot of the Calf). Also, the Guitarix plugin cabinet simulator seems not to work in Ardour 4 / Mixbus. So until I’ve sorted that out, I’ll be staying on Ardour 3

Ardour doesn’t ‘come with’ plugins, nor (unless I am very much mistaken) is Ardour 4 more restrictive about what types of plugins you can use, so I don’t see how they ‘disappeared’ on Ardour 4. A possible explanation is that Ardour4 has a different default path setting for finding plugins, but I’m pretty sure you can edit that, or move the plugins to somewhere that Ardour is expecting to find them.

I don’t know how much of that applies to Mixbus.

I had no issue after upgrade, for either Mixbus or Ardour… That is weird…

My main problem was that when I was listening to my tracks in Ardour 4, I was wondering why the guitars sounded so buzzy and grainy. I eventually figured out that cabinet simulator section of the Guitarix Amp plugin was not working - it seems to be bypassed. So all my guitars have the direct sound and no speaker, and that’s really no good. It’s no good because even if I worked around it and printed the guitars with the plugin directly to a wav file in Ardour 3, I could import that in Ardour 4, but I would still be unable to use Guitarix in Ardour4 until the whole plugin works…Of course I could send and aux and use Guitarix outside of Ardour with Jack, but that’s a real mission: everytime I want to plugin Guitarix it would involve a whole lot of other things.

I don’t really know what is going on… Anybody care to help me to get Guitarix to work properly in my system? I’m using the version shipped with Ubuntu Studio 14.04 64bit, which is probably already quite old…

To be quite honest I have a number of problems, which may require a reinstall - for example, Ardour 3, 4 or Mixbus are needing 4 or 5 attempts to load a session, before success.

I’m not a Guitarix user, but if you need 4 - 5 attempts before a session opens, your system might be seriously messed up, The session loading problem might be caused by a misbehaving plugin, so you could try to delete all plugins from a misbehaving session and save it as new “snapshot”. Then try to load the new snapshot with Ardour and if the loading problems are still there, then you have deeper problems than a misbehaving plugin. In this case I think you might save yourself a lot of time and trouble by starting from the beginning by reinstalling the os.

tl;dr: update to latest guitarix (git) and latest release calf (0.0.60) – or simply use KXStudio

Ardour4 since Version 4.2 is a tad pickier: All plugins that require a “fixed-blocksize” are ignored. At best they caused crackles at worst crashes. That’s not a new problem. Ardour3 also uses variable blocksize when automation playback is enabled.
Old versions of Guitarix amp/cabinet/convolver were affected by this, but recent guitarix overcame this limitation [1].

Invada and Calf plugins should show up regardless, they don’t provide information that would allow ardour to evaluate them. It really can’t be that they’re listed in A3 and not in A4. Ardour uses liblilv to index and discover LV2 plugins and that mechanism has not changed in ages.

Old Calf (< version 0.0.60) plugins may be responsible for the crashes at session load. It’s a concurrency/thread safety issue [2], meaning: it sometimes works sometimes does not.

[1] http://sourceforge.net/p/guitarix/bugs/24/

[2] https://github.com/FFTW/fftw3/issues/16
Ardour nightly builds since last week (>= Ardour 4.4-29) include an updated version of the ffw3 library which should fix crashes with plugins that use it (e.g guitarix amp, old calf)… might be worthwhile to check out http://nightly.ardour.org/

Thanks for the info. Everything was working until I installed A4. So I might just have to reinstall a new OS again

@AK65

I would STRONGLY recommend following x42’s advice first. The problem affecting the Calf plugins in particular was VERY intermittent and upgrading Ardour may have just revealed the problem that was being masked in older versions.

        Seablade

simply using kxstudio is a great suggestion… although some plugins are always going to be bad…