Massive distortion

I am running 2 Lenvov T60 Laptops with a radeon Video chip and Gentoo.
On both systems I am running the official binary build and even the Gentoo build.
I even have 2 cardbus cards and 2 RME Mulitface boxes.

Since a certain time I got MASSIVE distortion in the monitoring channel on both systems as soon as jack is started. These distortions
become louder when the input level becomes higher and even more if something moves on the screen e. g. window move etc.

All recordings are messed up with this distortions. It happens with all ardour versions 2, 2 binary and Gentoo builds.
I dont believe an Ardour issue but my hope is that someone can give me a hint where to find the reason for it.

Up to now I tried the following:

  1. ATI Driver downgrade - unsuccessful
  2. xorg-server downgrade - unsuccessful
  3. Kernel upgrade and downgrade - unsuccessful
  4. Recompiling the whole system - unsuccessful

Do you have a clue or an idea which could be checked further?
I am at my end … :wink:

Thanks a lot
Erdie

I forgot to mention, there are NO xruns anyway. The logs of jackd are clean. This really confuses me.

@Erdie

Since these are laptops, does it go away if you unplug the laptop from the wall?

      Seablade

This was what I tried at first :wink: Unfortuately not. I could create an audio sample to have an impression how it sound like. Tbh it sounds more like a digital issue, not analogue. BTW since it comes up on both devices, this must be a software problem. I do not know when it appears the first time because it was not detectable be a simple smoke test. But if there is a significant input on serveral channels, which the orchestra does, the distortion becomes huge (but it is not a simple overload).
My gues is it got a simple bug in an unknown component of the operating system be the usual “world” updates on Gentoo. And it do productive recordings every few month, therefore I cant say when it happens first.

I even thought about an issue in the alsa layer but this should then disappear by using a different kernel but it does not … :frowning:

i would try to install avlinux or something similar to one of the laptops and see if the problem persists. just to make sure it’s not the hardware. (even though it’s very unlikely as you wrote)

I had a similar issue. This does even occur after solving it, but only with some graphically intensive plugins (TAL Noisemaker e.g.)

OK, now how I solved it: I set the priority of the USB-handler to the highest priority (compared to other handlers) using rtirq. Don’t know much about how your devices are connected, but check rtirq!

PS: Of course you have to increase the priority of the irq-handler of your connection, not neccessaryly USB…

I can think of two things:

  1. If the above-mentioned video cards are discrete, do these laptops have on-board video cards, and does disabling the discrete video cards make the distortion go away?

  2. Go through http://gentoostudio.org/?p=maninstall and make sure all your systems are correctly configured for using audio on Gentoo. If something in there fixes it, please let me know, as I would like to document it as a specific issue.

@audiodef:
Thanks for your reply. Maybe i missed to mention both devices worked flawless at least for 2 years. I buyed them because it was the last Lenovo model with the cardbus I interface which is used by the Multiface. I did not change the configuration.
Anyway I will have a look if are there some option concerning the video chip. But it is the only one, you cant disable it. Hybrid graphics did not exist about 7 years ago when these laptops came to the marked. I will try to create an audio sample, too.

Here is an impression how it sounds:

I just put a mic in front of a loudspeaker and recorded a few seconds

thanks
Erdie

Has the graphics driver been updated? If so, maybe a newer version has a bug that’s causing this. Does downgrading the graphics driver help?

@Erdie

That is likely the sound of LOTS of xruns (dropouts) that you are hearing. I would be looking for a cause of those, and in particular, based off your comment that it gets worse with graphic activity, I would say looking for an IRQ conflict between your graphics card and audio device is a possibility. I would also confirm you do in fact have realtime permissions properly set up and enabled, and a kernel capable of it. Also what is your DSP reading in Ardour when this happens?

 Seablade

It sounds somewhat similar to the issue I had. And the distortion happened here without any xruns, too.

But you don’t wanna try rtirq, so I’m out…

  1. I downgraded the graphics driver for testing - no change.
  2. there are no xruns, totally clean (I mentioned initially)
  3. I did not change the realtime configuration since about 2 years when i installed Gentoo and it worked for the whole time without issues.
  4. The connected Multiface works flawless at my desktop computer with a PCI interface

You may beat me but the only things which may happen are some rolling release updates. After every update I make smoke tests but it seems to be that i did not detect the issue because the noise only comes up if there is a input level of about -10dB or higher. Otherwise you have the impression that everything is OK.

The issue I had was also unpredictable. It could have worked for days nicely, then only distortion all of the time.

@dbra: As soon as I get the time I will check what you suggested. I will let you know :wink:

Thanks
Martin

What about the distortion? Is it fixed? If so, how do you fixed it?

No success so far. I replaced the kernel with a new one including the full realtime patchset. This did not make any difference. Now I am sure that the issue must be somewhere in the application layer. When i record a test ton from one track to another, it crackles loud if I switch with the mouse between the Ardour main window and the mixer window. It must have something to do with the graphics layer. But where …? I guess this is a x86 but. This platform becomes less popular so I am almost alone with my problem,
BTW: I am wondering that irqbalance crashes when I try to start it on that machine. This is strange.

Don’t know irqbalance. I use rtirq. But I also think it has something to do with graphics, because here the distortion comes back every time I open TAL Noisemaker’s GUI.