Mapping MIDI control surface controls


I just bought Behringer BCF2000 control surface. I got it working with Ardour using guide at .

However, I found it a bit time consuming to map every control invidually. BCF has fader, pot and two buttons for each channel strip. I always want fader to be volume, pot to be balance and buttons to be mute/solo or rec-enable.

So, is there any way to map one BCF’s channel strip to one of Ardour’s track or bus with just one or two click?

That manual is out of date yes, but that was already in there;)



I have already tried Mackie emulation, but it didn’t work at all. When moving fader or changing any control it reported something like “received null” (if Ardour was started from terminal). Well, I’ll try that later today and report what happened…

Ok, I tried mackie control again. As I described in above post, any change in bcf’s control results in following message, if ardour is started from terminal.

Parameters between [ and ] vary

[b1 07 00] control for rotary [b1 07 00] is null

I would need to look into that more in depth, did you set your BCF to Logic emulation as decribed in those instructions? Also are you routing to the ardour_mcu port directly from the raw MIDI port, or are you using the ardour_control port?


Okay, thanks for your help. I hadn’t started BCF in LC mode. Now it is working.

I find it hard to see where a strip of BCF is mapped. Is there any way to make Ardour show the remote control ID’s of tracks and buses in editor and mixer windows?


Most logic control surfaces have an LCD so that it is shown on the surface itself, the BCF does not. One of the disadvantages of a cheaper surface.


@ghert: ardour has 3 options for remote control ID:

  1. follow order in editor window
  2. follow order in mixer window
  3. manually assigned

if you are using either of the first two options, and there are no bugs in your version of ardour, then the remote control ID is implicitly visible just by looking at the order in either window.

Hi All

I just setup a Novation ReMOTE SL Compact for use with Ardour/MixBus. Did it manually using Novation’s SL Compact Editor software. Used a standard template, not an Automap template. I have volume, pan, mute, solo for 8 inputs and the 5 mixes. MMC transport too. It all works.

Except: the MMC transport is weird and dangerous for recording.

First, when you click on the record button in Ardour it just arms the DAW – you have to click on play to start recoding. But when sending MMC RECORD, Ardour goes straight into recording (the tape rolls, no need to hit Play). Thought of that as a “feature”, until:

When you send MMC STOP while recording, Ardour stops recording, returns the playhead to the beginning of the take (if Auto Return is selected), and WIPES OUT EVERYTHING YOU JUST RECORDED!!

That’s more than a little scary.

Can anyone tell me why? And how to have MMC RECORD, and MMC STOP (while recording), behave exactly as the record, stop, and play buttons behave in the software?

Many thanks.

BTW be glad to share my ReMOTE SL MixBus template if anyone wants it.


I’m using Ardour 2.8.4 / MixBus 1.1 on OSX 10.5.8 BTW

MIDI Trace does not work it seems on OSX. Possibly because you can’t turn it on because MMC breaks even if you just open Ardour Preferences, let alone changing anything (like turning on Trace). If you open Preferences, you have to exit and restart to get MMC to work again. When you restart, Trace is reset to off.

@chanceoperation: Trace does work on OSX, but OS X directs the output into the Console window (Apps -> Utilities -> Console). And yes, the trace setting is not saved as part of the session or your ardour preferences.

Yes this is a bug we discovered just a couple of days ago. The ABORT flag is being set when it shouldn’t be by the MMC control. You can work around it by hitting STOP in Ardour before sending the MMC stop(If you need to bother sending MMC stop at all). The exact cause is being worked on.


@Paul: Glad you pointed out that Trace is not saved in Preferences. I have been watching the Console with no results. What I posit is that since I have to restart Ardour to get MMC back after even just opening the Preferences window, I never actually get Trace sending data to Console. Is that a known bug? Of course the workaround would be to save Trace status in preferences – then a restart to get MMC working again would presumably trace. So a bug and a feature request?

@seablade: Thanks for noting this bug. Note also the weird behaviour when using the MMC RECORD – might as well debug that while you’re in there.

Maybe this is an appropriate place to request a line or two to be added to that manual page…

It states very clearly how to properly connect to a BCF2000 under linux (looking at /proc/asound/cards to find the device under /dev/snd/midi).

I have one, and it works great on my linux box.

But trying to hook it up to my macbook (which I thought I’d successfully done at one point) I’m at a loss. I even thought I asked about it here already, but my search isn’t finding it. I know the device name under coresound. (BCF2000, imagine that.) But I’m not sure I know how to translate that into a proper device location for that entry in the ardour.rc file.

Heck, I might have it right for all I know, and maybe my problem lies elsewhere. But without knowing for sure that it is right, or how to check to see that it is… makes it kinda hard to definitively narrow anything down.

Here are the potentially relevent bits. They look right to me, maybe someone else can confirm? I am in Logic Control mode.

I have set the Ardour control surface option to Mackie. But it doesn’t work. Maybe it’s a routing thing? JackPilot is audio only. I do have MidiPatchbay, but not sure I know how to work it right. As far as I can tell everything midi is routed to ardour_in (including some BCF2000 stuff).

Whoah! Hey! I figured it out. Partially, at least. :slight_smile:

In Midi Patchbay, set the midi input to BCF2000 Port 1, and midi output to mcu_in. Now I’ve got transport.

But the faders aren’t quite right yet. They all start at the bottom and stay there. If I move one, the fader in ardour jumps to the bottom to follow it up. After I let go of the fader, it drops back to the bottom, but the one onscreen stays where it left off. If I use the mouse to adjust one onscreen, nothing happens on the bcf. Weird.

I’m leaving this all in here in case someone else hits the same thing, it’ll show up in a search.

Um route BACK from mcu_out to the BCF;)

Also the BCF has a couple of workarounds to get around its limitations that require editing a text file. And yes we are rewritting the manual and that is one thing I would like to address more throughly. However if you do a search on Mixbus and Mackie control, you will likely find several posts by me explaining how to set it up. Alternatively catch me in the chatroom (Go to Help>Chat) during the daytime in EST and I will help you through it.


Um route BACK from mcu_out to the BCF;)

Yes, I actually did think of that before that last post, and tried to do exactly that. :slight_smile:

Also the BCF has a couple of workarounds to get around its limitations that require editing a text file.

That’s no prob

And yes we are rewritting the manual and that is one thing I would like to address more throughly.

I thought so, just hadn’t seen anything about hooking it up on a Mac in either the “flossmanual” or “daisy” manuals yet. Speaking of which, I’d be happy to contribute to either or both, at least when I run into anything like that. How do I sign up?

However if you do a search on Mixbus and Mackie control, you will likely find several posts by me explaining how to set it up.

Just tried those exact terms, and the first result is a direct hit:

Thanks! i just wasn’t using a broad enough search… was specifying BCF2000 and OSX rather than mackie control.

Alternatively catch me in the chatroom (Go to Help>Chat) during the daytime in EST and I will help you through it.

I may do that if I don’t find the answer soon. (Brought the laptop & bcf2000 to work w/me, but can’t play with 'em till lunchtime of course.) Thanks!

When I left off, I was trying to connect back to it via Midi Patchbay, without luck. It shows up as 3 pairs of midi ports, but connecting mcu_out to any of the inputs wasn’t working for me. I’m sure it’s something simple, and I’m getting pretty close. Kinda funny this is less intuitive for me in OSX than in linux. :slight_smile: No fault of Ardour though… I’m just not a midi whiz and using Midi Patchbay isn’t nearly as simple to me as Qjackctl.

OK, it’s working fine now. Not sure what kind of fumbling I was doing when trying to route mcu --> bcf2000 last night, but I had either it or something else wrong.

Here’s an easy step list:

  1. Edit ardour.rc as the manual says. For OSX, entries in the device line will look like these…
    MIDI-port tag=“mcu”

  2. Power on the BCF2000; make sure it is in Logic Control Emulation mode.

  3. Open Ardour with a new or existing project.

  4. Open Midi Patchbay.

  5. By default, one route is listed. Set the input of that route to BCF2000 Port 1.

  6. Set the output of that route to mcu_in.

  7. Click the “Add Patch” button to create a second route. Set the input of that route to mcu_out.

  8. Set the output of that route to BCF2000 Port 1.

  9. Save these Midi Patchbay settings to make them easy to recall in the future.

  10. In Ardour, go to “Options > Control Surface” and select “Mackie”. If already selected, unselect it and select it again.

  11. The faders should jump to positions matching the tracks in your project. That means it works.:slight_smile:

That’s it. Note that anytime you want to use the BCF2000, Midi Patchbay will need to be running, with those “patches” active.


Hi Guys,

I’ve been working with my Remote Zero SL to get it integrated with Ardour and my only remaining issue relates to the fader control.

Transport works great using MMC and the faders are responding perfectly using CC with unique midi channel assignments. However, for some reason when I move up the fader on say channel 2 the solo button arms on channel 1. The same relationship exists up the line where each fader responds perfectly but sets off the solo button on the channel directly above.

When I decrease the fader volume to 50% the solo button disarms.

Any suggestions on how to address?


Ramin Streets

Hey Chance,

i just got a ReMOTE ZeRO SL (i think i just gagged a little typing like that), and I’d LOVE to try out your automap template for ardour/mixbus. i don’t see a way to private message or email, so feel free to bug mine.

regent at