Map Akai LPD8 MIDI control interface to Ardour

I’m using an Akai LPD8 (a small 8-pad, 8 rotary knob MIDI interface) successfully with Hydrogen but I’m having trouble getting ctrl+ middle click assignments working in Ardour.

I followed the instructions here:

at one point, ctrl+ middle click got the appropriate sliders assigned to the Akai’s knobs. But it only worked once when I first tried it. Despite hours of effort yesterday & today I haven’t managed to the ctrl+ middle click box appearing again.

I’m definitely a noob when it comes to midi; any pointers for me? I feel I may be missing sthg obvious.

Am running Ubuntu Studio, Jack & Ardour 2.8.6

@pleasebus: make sure you have enabled the option for this (in the Options menu). This is the most common error people make with this. There is an argument that it should be on by default, just as there is an argument for just about everything :slight_smile:

1 Like

@paul I’ve followed the manual, but the window prompt doesn’t appear for me.

Enable Generic MIDI control: Options -> Control Surfaces -> Generic MIDI
Connect Ardour’s MIDI port named “control” to whatever hardware or software you want (using a MIDI patchbay app)
Ctrl-middleclick on whatever on-screen fader, plugin parameter control, button etc. that you want to control
A small window appears that says “Operate Controller now”
Move the hardware knob or fader, or press the note/key.
The binding is complete. Moving the hardware should control the Ardour fader etc.

My LPD8 midi out is connected to Ardour midi in 0:control in Jack. The equivalent process in Hydrogen is working for me (Tools -> Preferences -> Midi System -> click red “event” button)

I also tried the autorouting options (Remote ID follow order of Mixer) but this has no effect.


If the window/dialog/prompt is not appearing 99.99999% of the time that means you have not enabled the Generic MIDI protocol as told to in the first step there. Note that you have to do this per session, so any time you create a new session you have to do this(Template sessions I believe are the exception to this).



Generic Midi is ticked - so maybe I’m in the .00001% :frowning:

A little more info: I am able to get the controller talking to Ardour of a fashion. The controller comes with a preset editor which I can run under Wine.

Problem is, it will only define #CC actions per midi channel. So in Ardour, I can get it to operate on each fader individually but not along all faders. I’m trying to set this up so the controller works each fader in turn on 8 tracks.

I also can’t work out the #CC codes - #0 is Solo, #1 is Mute, #2 is Record, #3 is Level #4 is Pan (but only for the left on a stereo track). Switching on Ardour Control Surfaces Feedback allows pads to light up for Solo, Mute, Record if they’re appropriately assigned, which could be useful. After CC#4, nothing seems to have an obvious effect on Ardour.

Obviously, it’d be far easier if I can use ctrl & click middle to do all these assignations.

What is the output on your console when you open that session and enable/disable the Generic MIDI Protocol. Also check the error dialog as well please. Put them on pastebin or on here surrounded by the PRE tags and give a url if it is on pastebin.



Thank you for your help

The console output seems to be saying it’s found a Mackie control; toggling Generic Midi gives the error in the final line on each toggle. I use a 1010LT here but the Akai controller is connected to USB. Where would I find the error dialog?

This is free software, and you are welcome to redistribute it 
under certain conditions; see the source for copying conditions.
theme_init() called from internal clearlooks engine
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/paul/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/paul/.ardour2/ardour.rc
ardour: [INFO]: No H/W specific optimizations in use
ardour: [INFO]: looking for control protocols in /home/paul/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
ardour: [INFO]: Control protocol Tranzport not usable
ardour: [INFO]: Control surface protocol discovered: "Mackie"
system template path = /usr/share/ardour2//templates
loading bindings from /home/paul/.ardour2/ardour.bindings
Session writable based on /studio/recording/testmidi/
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave

Ok I gotta take a look at this from my work this afternoon, though getting help on IRC may be the best option right now, I should be around some this afternoon at least, and tomorrow.


Thanks to all on IRC for sorting this out. I ended up upgrading to the latest Ardour SVN, but am pretty sure that isn’t what fixed it. If anyone has similar problems, I suggest deleting/moving your Ardour profile. I did that and nothing changed, but when I returned to my old profile, ctrl+mid-click started working again. Check what’s happening by launching Ardour from the terminal (ardour2) and enabling trace in Ardour for your midi (alt+O and switch on trace input for control port in the MIDI tab).

To make the Akai LPD8 work, ensure you are in CC mode on the LPD8. Use the controller’s editor under Wine to have the pads run in toggle mode, not the controller’s default Momentary mode. You might run into conflicts if your LPD8 Editor under Wine has sent CC numbers to the hardware that overlap or duplicate. Make sure each button is assigned a different number.

Ctrl and midclick with the cursor on the Ardour item you want to control and a window will pop up asking you to move something on the controller. The assignment is then set. To remove an assignment, ctrl+midclick to get the window popup and then right click to dismiss it.

I assigned one row of knobs to the levels on three tracks + the master, then the second row to pan those tracks. Of course you could just set them to run 8 track levels.

Then I set the pads to operate the mute and solo switches. The pads light up when these switches are on (you don’t need feedback in controller options to do this). You have to give the pads a heavy tap to register; there’s no way of adjusting sensitivity.


1 Like