Mackie Onyx i

Has anyone have a view on the new Onyx Series i Firewire mixer desks. In particular their compatibility and integration with Ardour, and any driver/software requirements.


You need to check here:

It appears the ‘i’ series is not supported yet. The ffado guys are working very hard but the hardware folks release the new stuff with completely different chipsets which require a complete rewrite of the drivers in many cases. Firewire on Linux is very rarely going to support the latest release of ANY hardware and few companies are actually being helpful in providing source code. That said the amount of new supported deviced in the last 6 months is amazing, but check the list first…there are a lot disappointed purchasers out there that bought first and checked later…:frowning:

Thanks for your help and advice. I will check the list. :slight_smile:

I have a 1640 and a 1620 - not the i series. Both with firewire cards. The original Onyx series with firewire is supported. I use them both together on my Linux DAW with Ardour.

I’m not impressed with what I’ve read about the i series. My understanding is that the “big improvement” is some hacks to let these mixers work with ProTools. Yay.

I wasn’t impressed with Mackie’s crappy support under Windows, either. The XP driver for the original series was supposed to support two mixers in parallel or series. This was rather iffy in practice, and Mackie took the lazy route and decided to stop supporting dual-mixer configurations in Vista and presumably Win7 (by this time I stopped caring). Under FFADO - works great!

If you really want an Onyx and really want to use Linux, and you want it now, go with an original Onyx series with firewire. The 11640 is a nice small format mixer that won’t break the bank, if you’re looking for something to sit on your desk or even go on the road with you. If FFADO says the i series is already supported, then there’s no reason not to have the latest toys.

Based on what I said above, when I get another mixer, it’s not going to be Mackie. I’ve used Mackies for a long time, and I’m disappointed with the way they’ve been doing things of late. Sloppy driver work, hacking other people’s products instead of creating new ones - gah.

Mackie is not known for high quality, and for good reason:)

That being said, I picked up an iSeries here. I had a very specific purpose I needed filled that it did. But I haven’t tested it on Linux yet, I wouldn’t hold my breath for it to work though as I don’t think they got the innards from Echo on these, but I am not sure.

Really what I really want is to rip out the preamps(And maybe EQ) and rackmount them for standalone use;)


Does like the Onyx pres sadly.

Has anyone out there had any success with the Saffire PRO 40. It is listed in the Supported Equipment as Experimental. I am running Ubuntu Studio 10.10


I need to check both the i-series(Which I don’t expect to work) and my Saffire to see how both of them work in Linux. I have both of them here but I have only used them in OS X.


Well nothing like being over a year late to the party. I just confirmed my i-series is working on Linux, I haven’t done very in depth testing but was getting signal to it over firewire, and have no reason to think there would be a problem getting signal from it back to the computer. Haven’t pulled in my Saffire yet though.


Very newbie question: is the Onyx usable as a control surface with Ardour? That is, does it map to the ardour pan/gain/mute/etc. controls?


The onyx doesn’t transmit any control signals to be able to use it as one for any software, so no.

Yes, I actively have/use one (a Focusrite Saffire Pro40). It works under Ubuntu Studio 18.04 (I run it with KXStudio on top). But, when you open FFADO for the first time, it is recognized, but the mixer panel won’t load (that may look disturbing, but you can simply quit/close the window and the device still/just works). So, not being able to load the mixer panel in FFADO is not a problem, because it simply works with Jack (128 samples, buffer 3; 2.7 ms latency) and with Ardour; it is recognized there and all the channels are there and selectable/usable. If you per sé want the mixer panel of FFADO to load you need to upgrade FFADO to version 2.4 (but in practice it is not really needed to mix from the soundcard itself). But, I tried that as well, with a ppa I found somewhere (I removed it again and cannot find the PPA any more). So, I also tried the mixer in the newer FFADO version with the PRO 40, and that works also, but (for me) the (FFADO) mixer panel for the Pro40 is very complicated to understand and use. I decided not to use it. So, I can confirm it definitely works.