Mackie Onyx Firewire in a Linux World?


I’m a long time Windows (TOO LONG?) user trying to convert. I’m trying to get the new Ubuntu Studio/Ardour to recognize my Mackie Onyx Firewire card. I’ve searched several forums but find old references to the Mackie stuff and answers that say it is or will be supported in Frebob, Jack, this, and that, but I’ve not found any specific reference to how it is atually done. I think the Onyx is great, but Mackie should get a jab in the eye for the lack of driver support.

I’m wondering if I am trailblazing here despite all the old forum threads or has someone else actually made this work and care to share?

PC hardware is Dell/Intel Dual core

Go here: (formerly FreeBob)

From their homepage:
11/09/2007 - 11:23
"Today we received the Onyx Mixer with FireWire expansion card Mackie provided us with. This means that the FireWire option card for the Onyx Mixers will be supported in the upcoming FFADO release.

Note that currently only the Onyx Mixers are supported, NOT the Onyx 400F, 1200F or Satellite."

firewire audio devices are supported by the ‘ffado’ project, formerly known as freebob. a list of supported devices is at:

ardour doesn’t need to recognize any sort of audio interface. as long as your card is supported by alsa, or freebob, or whatever, jack and ardour can use it.

according to the ffado/freebob page listed above, the onyx should be supported.

i’m pretty sure that ubuntu studio includes ffado/freebob by default.

now, if you’ve also got integrated sound on your computer, it’s possible that it is being treated as the default audio interface, not the onyx. if you’re using qjackctl as a front-end to jack, in the ‘setup’ section, you can choose which of your audio interfaces you want to use.

hopefully, that helps.

It should work. In qjackctl, choose Driver: freebob

You may need to set sampling rates and such also to match the rate used by the Mackie.

If it still doesn’t work you might have a little configuring still to do. Try these two links:

Probably not every single feature will work yet. This will come as and when there is a first release of FFADO. But the good news is that Mackie are supporting the FFADO project, so you should expect great driver support to come.

Real Onyx + Ardour exprience.

Yesterday I attempted to use Onyx1640 + Firewire Option to record 16 channels of audio at 88200 kHz 24 bit in Ubuntu 8.10, Ardour 2.5.

Jack and ardour are working and recognizing the firewire card, given You started Jack first and configured it to use freebob.

The problems started when I began recording real tracks (I was recording a concert), after 1 song Ardour given up saying that hard drive could not keep up to Ardour.

I tried all same in Windows, Tracktion software, showed No problem at all on same machine and hard disc.

I wanted to do recording in Ubuntu but was forced to go WinXP.

I think if I had mabe 7-8 channels ardour would record without problem, but I am not sure.

To get rid of xruns,

it might be nessesary to configure jack to run only recording (no playback). At least it worked in my case.

I am trying to configure my computer to use a Mackie Onyx Satellite.
I’ve used a presonus Firebox with it before using the ffado driver. It works great. However, it was my friends and I would like my own. What did you do to configure your Onyx?
Any help would be appreciated. Thanks.

First, I followed all guidelines regarding allowing the firewire for my user, realtime settings and others related adjustments.

When You connect Onyx Firewire card, then start qjack and use settings to choose freebob driver (instead of alsa), than choose required sampling frequency and buffer size. That’s all.

Close settings window, applying settings, and start jack.
Now, If You start Ardour and create new session and add required number of tracks - You will see them all assigned to appropriate input channel of a firewire sound interface.

It is important to first start jack in this mode, than launch ardour. At least, this worked for me.

I wanted to come back and delete my post. I originally posted some jack output and stuff. It turned out that I had my Mackies plugged into a Firewire bus my system was not seeing. Once I ran gscanbus I found that the Firewire ports on my Soundblaster were very visible, plugged the Mackies into those and jack started up.

Now on to see about using Ardour.

I have a Mackie Onyx Satellite, and I’d love to be able to use it with Ardour and Linux. I’d like to know which settings will work in Jack.

NOTE: The Onyx Firewire Card and the Onyx Satellite are NOT the same thing. The Firewire Card is the expansion card for the Onyx series of Live Audio Mixers.


The Satellite is probably not going to work, as it is an ‘Unknown’ status in FFADO, which provides the firewire device support for Linux Audio primarily. As such there may be a slight chance it would work and just hasn’t been tested, but I wouldn’t hold my breath, and certainly wouldn’t buy one for use in Linux;)


Oleg – Which file system where you trying to record onto under linux

Danny, sorry for late answer - my filesystem was the default one for Ubuntu then which was ext3 I believe. Is there some other recommendation for Ardour?

Generally, everyone can You share here which is the maximum channel count You were able to record with Ardour (given the hardware restrictions, of cource)

I had HP Pavillion notebook (2GHz , 2GB and so on - entertainment series) and was able to record 10 channels at 96/24 for 5 minutes before Ardour said disc cannot keep up to it.