Mackie Control Universal (not Pro) with USB MIDI interface


I recently got a Mackie Control Universal with two MIDI ports, no USB, so I’m trying to use it with a Roland UM-ONE. I’ve read that it worked with Logic, but I can’t get it working with Ardour. I’ve read the manual, but maybe I’m doing something wrong.

  • The UM-ONE is connected to my conputer, and the USB LED is lit;
  • It is connected to the Mackie Control Universal: OUT in the OUT port, IN in IN;
  • I’m using “a2jmidid -e”, and I can assign IN and OUT to the UM-ONE via Ardour;
  • I’ve tried “Mackie Control” in Ardour. The OUT LED flickers continuously on the UM-ONE, and the “Assignment” red light stays lit on the MCU. Nothing more happens, except my first track is on “Record” mode and I can’t deactivate it;
  • I’ve tried “Mackie Control Universal Pro”, but nothing happens. I can sometime see the OUT light flicker on the UM-ONE when I click on “Discover”, but that’s it;
  • When I press a button on the MCU, the IN light flickers on the UM-ONE, so I think it’s getting a signal;
  • I tried “Generic MIDI”, but nothing happened.

So Ardour doesn’t seem to be able to communicate with the MCU properly when using a USB MIDI interface. Is it a problem on my part, or is it just a silly project from the start?

I’m using Manjaro Linux and Ardour 6.9.

Thanks in advance for your help!

“It is connected to the Mackie Control Universal: OUT in the OUT port, IN in IN”

When it comes to MIDI DIN cables, aren’t you supposed to connect the IN to the OUT and the OUT to the IN?

Yep, that’s what I did first, in fact. But nothing. On “Mackie Control”, the OUT LED flickers on the UM-ONE, but it receives nothing when I press a button on the MCU.

But the MIDI ports don’t even need to be plugged into the MCU to do this, in fact. So it doesn’t matter if OUT goes in IN ou OUT, the same thing happens. Except the only way I can get the IN LED to light up on the UM-ONE is to plug IN in IN and OUT in OUT.

So it seems Ardour can send a signal to the UM-ONE, but it can’t reach the MCU for some reason. But maybe the DAW tries to communicate with it via a MIDI port that simply doesn’t exist?

Sometimes, when I toy too much with the Mackie menu, I also get this error:
Failed to register port "mackie control in", reason is unknown from here

I have to restart Ardour, then.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.