M-Audio on Ubuntu


I am new to Linux and Ardour, somehow decided to try Linux (simple Ubuntu 9.04) as a second system for all Internet needs near Windows, which I mostly use for audio. So tried Ardour, even compiled ver. 2.8.7 from source and it works. Recently got a bunch of tracks - the live concert recording done at 48K/24bit. At my studio I do everything at 44.1K/24bit and did not bother to try other rates in Linux, as I have to mix files for video, I decided to load 48K into Ardour, to play with it, but as I changed rate in Jack to 48000, Alsa refuses to load, Jack message is the following:

18:59:46.445 Startup script…
18:59:46.445 artsshell -q terminate
sh: artsshell: not found
18:59:46.848 Startup script terminated with exit status=32512.
18:59:46.848 JACK is starting…
18:59:46.849 /usr/bin/jackd -R -dalsa -r48000 -p1024 -n2 -D -Chw:1 -Phw:1
18:59:46.852 JACK was started with PID=3438.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver …
apparent rate = 48000
creating alsa driver … hw:1|hw:1|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:1
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: cannot set hardware parameters for capture
ALSA: cannot configure capture channel
cannot load driver module alsa
18:59:47.409 JACK was stopped successfully.
18:59:47.409 Post-shutdown script…
18:59:47.410 killall jackd
jackd: no process found
18:59:47.820 Post-shutdown script terminated with exit status=256.
18:59:48.897 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

Still could not find solution. The sound card is M-Audio Audiophile 192, it works with 44100 rate in Ubuntu, and is capable
to work with 48, 88, 96. I would be grateful to get some help here, to get deeper knowledge, and maybe migrate from Windows some day. Thank You

This is a problem with JACK/ALSA, not with Ardour, so I think you should post it in a forum for ubuntu sound configuration or search for AP 192 under linux …
Anyway, I’m using ubuntu myself and I’ve even applied a kernel patch to get an M-Audio fast track ultra to work. I remember this worked only at the default sampling rate of 48 kHz.
It seems M-Audio uses non-standard methods to set the sampling rate for certain interfaces, but I’m not shure concerning the AP 192.
If 44.1kHz works and nothing else, this is probably the case. Did you only change the sampling rate ?
First you should get alsa working with 48 kHz. My experience is that ubuntu 9.10 works better with jack/alsa - in my case because of better support for shared interrupts (with RT-kernel, chrt, /etc/security/limits.conf, …) but particularly there should be a newer version of alsa included.
So get the newest alsa, visit http://alsa.opensrc.org/index.php/Ice1724#Alsa_driver_ice1724 and http://www.alsa-project.org/main/index.php/Matrix:Module-ice1724, compile with correct settings (at least ./configure --with-cards=ice1724 --with-sequencer=yes) , adapt configuration files like /etc/modprobe.d/alsa-base and ~/.asoundrc and maybe … four weeks later …
linux requires good research, willingness of experimentation and a lot of patience :slight_smile:

Thanks, I will try your suggestions, four weeks is ok :slight_smile:

And I tried to change a lot in Jack set up, nothing helped

As much as I have seen, the AP 192 is not tested by the alsa developers but there are some people out there who got it working.
Audiophile 2496 is fully supported, I suppose.
alsa-utils provides several programs to test functionality.

Another thing that might be interesting for you …
Unfortunately ubuntu doesn’t provide jack support for amarok and kaffeine, but you can achieve this by installing the older versions (1.4 btw. 0.8.7) from older sources - also check for /usr/lib/xine/plugins/1.24/xineplug_ao_out_jack.so - I had to build libxine1 from source, but maybe this is fixed now.

Anyway, you can go to ubuntuforums.org and ask people there.

Thank You, I will try ask in Ubuntuforums and also play with alsa utils

AP 192 is also supported by OSS, at least this should work
(with correct settings…)

i dont know if the guy ever tryed oss4 … but it wont work right on oss4 either for some reason was the experince i had. the mixer controls have no effect. but the /dev/dsp is working for capture.