M-Audio Firewire Solo

I have this device (the M-Audio Firewire Solo), and thought I’d give a shot at using it to record some things with Ardour.

I found a really helpful, and specific tutorial on how to accomplish this, but I am having a great deal of difficulty. Here is a link to the article:

Some basic info about my computer:
Motherboard: ASUS A8N-SLI (I’m using the on-board firewire)
Processor: AMD Athlon 64 x2 4200+
Memory: 3 GB
Operating System: Fedora Core 8
Remaining free space in Fedora’s partition: about 100 GB

I have an internal sound card, and an external sound card for my computer. I fried the internal one years ago by hooking it up directly to my guitar amp (it was a powered output). I don’t intend to use my external sound card at all during recording, but maybe it’s existence is important somehow.

This isn’t really a problem, but I am using ALSA drivers for my external soundcard. Ardour doesn’t seem to like that setup at all. If I choose to use the ALSA drivers at the startup screen of Ardour, then Ardour freezes indefinitely.

In the above link, it says you need to install the following in the following order: jack, qjackctl, freebob, and qt4.

So far I have installed jack, qjackctl, and ardour without any problems.

I’ve tried, “yum install libfreebob”, and yum reports that libfreebob is already installed with the latest version. I get the same results for “yum install qt”.

To be on the safe side, I downloaded the source tarballs for the latest versions of both freebob and QT4. I haven’t got around to actually trying to build QT4, but freebob has just been trouble. ./configure fails saying, “no package libraw1394” found. So I tried, “yum install libraw1394” which reports that libraw1394 is already installed with the latest version.

I figured that it’s possible I already have everything I need installed, so I just moved on and configured jack the way that the tutorial said. Then I opened up ardour. Note that in order for me to get ardour open I have to use the dummy sound driver because the driver list doesn’t have any others that will allow ardour to start. Once ardour opens it shows up in the qjackctl interface (like the tutorial said), except there is no presence of freebob (just ardour and dummy_pcm). I didn’t expect things to work, but to be sure I connected dummy_pcm to ardour and tried to record. As I expected, only silence was recorded.

I think the problem boils down to this:
Either I already have freebob installed, and I just need a way to make it show up in either ardour or jack.
I need to install freebob, but in order to do so I need to figure out the problem with libraw1394.

Either way, I don’t have a clue what to do. Hopefully I can get some helpful advice here.

Wow… thank you very much!

I installed the -devel package for libraw1394, and ./configure threw a few more fits, but yum was able to install the devel packages for everything else that freebob needed just fine. So ./configure finally succeeded, and I was able to make the build without any errors.

I also installed qt-devel .

Now, I’ve technically met the perquisites for the tutorial in the link, but the problem is still the same as before. I restarted my computer, but why do you think freebob doesn’t show up in the connections list for qjackctl?

I should point out that qjackctl produces the error, “Could not connect to Jack as client” whenever ardour is not started. Otherwise qjackctl runs smoothly. Could it be that qjackctl doesn’t have any connection to jack?

oh, and you’re right It is probably time I upgrade fedora to a newer version. It’s crazy how fast they put out new releases. I installed this OS only about a year-and-a-half ago.

I guess i’m just a little reluctant to upgrade because this is easily the most stable linux install I’ve ever had, and it took sweat+tears to get it this way. I’d hate to loose that.

I’d really suggest you try the Planet CCRMA route first, before attempting to compile stuff yourself. You can/should still follow the tutorial just skip the compilation parts.

You also might want to seek help through IRC (http://ardour.org/support) instead of this (slow) forum.

Fedora Core 8 is a bit old (Nov 2007). I’d recommend upgrading to 10 if possible or at least installing the Planet CCMRA packages (http://ccrma.stanford.edu/planetccrma/software/installplaneteight.html).
Jack in particular needs to be compiled with libraw1394 for freebob to work out-of-the-box.

If you want to compile things yourself you need the -devel package installed, so in your case you’d have to do ‘yum install libraw1394-devel’ and so on.

And you shouldn’t use Ardour directly on ALSA. It’s designed to use Jack which in turn should use ALSA or, I guess in your case, FreeBoB or the new standard FFADO. And Jack is easiest configured and started through qjackctl.