M-audio fasttrack...

I am trying to setup ardour with a m-audio fasttrack. I get jack started but I dont see any of the outputs (guitar/mic) from the m-audio in jackctl… I was just wondering if anyone has messed with the fasttrack and ardour?

My os is ubuntu dapper drake.


How did you get on with this? I am curious as I will be trying to use the fasttrack usb with Linux and Ardour…

Chris M

I had it working and I’ve come to the conclusion that the m-audio fast-track pretty much sucks… It’s the whole usb 1.1 thing…what was I thinking?

For my purposes, I’ve gotten better results from a sound blaster live.

I’m going to stick a midrange card fairly soon…

Check and see how many ALSA devices you have. I have an M-Audio Fast Track Pro that creates two ALSA devices (hw:0,0 and hw:0,1), and all of the inputs are on the second device.
Hope that helps.


i am using maudio Fasttrack-USB with jack and ardour.
it was recognised at boot by ubuntu dapper and demudi,

i switched to xubuntu again, since there was a crackeling in the audio at lower latencys without errors or occurance of xruns in demudi, and i wasnt able to fix it.

has anyone experienced something similar?

in case your problems are not solved yet:

have you got the snd_usb_audio module loaded? (loock with $lsmod)

$lsusb gives a line like:

Bus 001 Device 003: ID 0763:2010 Midiman

if ok, see if the soundcard is recognised by alsa or go to to the
alsa-page covering Midiman/MAudio

For information on hardware support, read http://ardour.org/system_requirements/audio_compatibility .

Anyone tried an M-Audio firewire 410? ive got one of those connected to my laptop via pcmcia firewire controller , im not sure if you can even get them to work under linux ?