M-audio fasttrack pro (or alternatives) on linux


I’m looking for an audio-interface (USB, budget < €200). I want to use it with Ardour on Linux.

A list of cards in that price-range:

  • M-audio fasttrack pro
  • Alesis IO4
  • Focusrite Saffire 6
  • Tascam US-series

Most sites say the M-audio Fasttrack Pro has great Linux support, but the ALSA wiki (http://www.alsa-project.org/main/index.php/Matrix:Vendor-MAudio) says: “Reduced functionality in class-compliant mode, patch available for more features.” (Link with patch is dead)

Any idea of what this exactly means?

Are there other cards (USB, budget < €200) supported?



I can’t speak on the other boxes/cards, but I have a M-Audio Fast Track Pro and it works beautifully. (Just got done recording something just now).

The patch you’re asking about is to enable certain functionality that doesn’t work out-of-the-box. Without the patch, the FTP can only achieve 16bit/44.1KHz quality recordings. After the patch, you can record at 24bit/96KHz and the digital outputs are enabled as well.

That said, I did a bit of playing around with the FTP before compiling a new kernel and it worked quite well. However, I have to say that the performance and sound quality is top-notch with a patched custom kernel.

The FTP is also built well. It’s probably the most well-rounded I/O box for the price. I was told (I don’t know if the guy was reputable) that the lower-end Alesis I/O boxes were throwaways. I did a quick google on the Focusrite and it looks like a great box. However, after a quick Google, it would seem Linux users were having trouble with getting it working (albeit, the thread I found was from a year ago).

I’d say the FTP is a safe bet and seems to be well supported in the Linux audio world.

EDIT: I just watched some videos on the Focusrite and that box looks really great. Solid as a rock.

@joegiampaoli: awesome writeup!

Thanks Paul, now we have a nice guide for all newcomers asking about this device

@ isaacj87:

Yes, the Fast Track Pro will probably soon be supported by ALSA, on the older version of my blog there was a high number of users who had succesfully patched and compiled their kernels, just a few days ago i received an e-mail from someone who is adding me to some ALSA mailing list, I guess to sort of prove that there is a huge demand to add this device to ALSA, I really don’t know how that works, I have to focus more now on my music, but I don’t know why they have never supported this device 100%, it’s been around for a while and quite popular and still no support from them, so keep your fingers crossed. It’s a nice device and the converters are pretty descent…

@joegiampaoli: woow, nice tutorial!!

I’ll take the FastTrack Pro then …

Thanks to all for the advice !!



I’m glad to see that you’ve put the guide back up. I was one of the users who successfully compiled the kernel. IIRC, I was asking you about the .33-rt kernel on the old site. It’s unfortunate that the Nvidia drivers don’t work with RT kernels newer than .31.

Congrats on the ALSA mailing list, I hope to see official support for the FTP soon. Thanks for making time for our little device. :slight_smile:

Just as an addition to Timmy’s request, I have an excellent Akai usb card which I don’t know if it is supported, as it’s plug & play( well, strictly speaking, not just a usb card…it’s powered speakers too!!) I recently (May) purchased the RPM3 monitors, & as a result, my xruns no longer exist!!
I switch between Mixbus 1.5 & Ardour 3 A9 & on both, I get really good performance!! For a set that cost me £84, I was startled at how good it was, given that in the past I have spent about £500 on M-Audio Conectiv & Stanton Final Scratch 2, which with both I got xruns, (I’m a scratch dj at heart!).
I whole-heartedly recommend the Akai RPM3’s to anyone (the RPM8’s are around £800!!) as a budget solution to a desktop studio, but with professional performance at a price that won’t break the bank!! I have an MPC2500 & it sounds SOOOO crisp through them!!!
Anyway, enough babble, I just thought I’d contribute!!

Just to chime in: An excellent, excellent interface is the Cakewalk/Roland ua25-ex. Just got one to use for software testing with my gentoo netbook. Completely class-compliant USB, not housed in plastic, and has optical in/out for using those nice (or cheap) 8-channel ad/da converters!

Hmm, does it have enough bandwidth to connect more channels via ADAT, in other words, is it USB 2.0? Can’t see anything in the specs http://www.rolandus.com/products/productdetails.php?ProductId=970

I’m thinking of buying a M-Audio Fasttrack Pro 8R. Are these informations you mentioned valid for this too?
What do yout think about that device? Is it as good in price/value ratio as the simple FTP?

the Cakewalk/Roland ua25-ex... has optical in/out for using those nice (or cheap) 8-channel ad/da converters!
I checked because that didn't seem likely, and I think you'll find that it's IEC60958 which is only able to carry two audio channels. Also I suspect you can have either digital or analog inputs, but not four channels at once. All the same, it does look a very nice two channel USB interface.

Hi joegiampaoli
I’m really new to linux and trying to install the fast track pro.
I followed your script and when I type “make menuconfig” I get this message:

HOSTCC scripts/basic/fixdep
scripts/basic/fixdep.c:106:10: fatal error: sys/types.h: Aucun fichier ou dossier de ce type
#include <sys/types.h>
compilation terminated.
scripts/Makefile.host:118: recipe for target ‘scripts/basic/fixdep’ failed
make[1]: *** [scripts/basic/fixdep] Error 1
Makefile:412: recipe for target ‘scripts_basic’ failed
make: *** [scripts_basic] Error 2

What should I do?

This is a very old thread, and I think the information is obsolete. I believe these devices just work now.

I’m running to work now, but I can give more details later.

thanks for replying to me.
I know it’s an old thread but I just got a used fast track pro and don’t know how to record with it on ardour and it’s the only info I found.
Can’t wait for your details!

I went to make sure I knew what I’m talking about, and apparently I don’t. I have a Fast Track Ultra, and I assumed the rack-mount version would be the “Pro,” but it’s not. I don’t know if the internals of the “Pro” are related to the “Ultra,” but if they are you may be able to just plug it in. With the “Ultra,” I had to open alsamixer and ensure that each analog input was turned all the way up only for its corresponding digital output, (and maybe vice versa, I don’t remember). Everything else should be turned down.

Sorry for the misinformation. I hope you get it working.