M-Audio Fast Track Pro and recording?

Hello everybody!

Has someone got the Fast Track Pro from M-Audio working with Ubuntu Edgy? I get sound from music players but I can’t use the analogue audio INs from the front.

“arecord -f dat -D dsnoop -d 10 test.wav”

This command works and creates a test.wav but there is nothing to here. So how can I select the individual Audio INs.

Here are some details about the system:

…@…:~$ cat /proc/asound/cards
0 [Audigy2 ]: Audigy2 - Audigy 2 ZS [SB0350]
Audigy 2 ZS [SB0350] (rev.4, serial:0x20021102) at 0xc000, irq 12
1 [Pro ]: USB-Audio - FastTrack Pro
M-Audio FastTrack Pro at usb-0000:00:02.0-2, full speed

Here is my “ascounrc”


Here is the output from arecord -l and arecord -L:


It would be nice if I could understand how I can get them working.

I’m looking forward getting your answers!

Regards, Denis

I want to add some additional things. I get 2 PCM capture devices listed in qJack and 2 PCM playback devices. I connected them but when trying to record something with ardour it doesn’t work either.


I got it working but I can only access the outputs 3 and 4. The funny thing is that I get an output signal through 1 and 2 using audio with other apps. (exaile, flash, etc)

Is there a sound server (arts,esd etc) running that is using outputs 1 and 2?

There isn’t.

“…@…:~$ ps -C esd

How about “lsof /dev/snd/* /dev/dsp*”?

for dsp I get nothing and for

ls /dev/snd/* I get the following:

controlC0 hwC0D2 midiC0D2 pcmC0D0c pcmC0D2c pcmC0D4c pcmC1D1c timer
controlC1 midiC0D0 midiC0D3 pcmC0D0p pcmC0D2p pcmC0D4p pcmC1D1p
hwC0D0 midiC0D1 midiC1D0 pcmC0D1c pcmC0D3p pcmC1D0p seq

I have a Audigy 2 ZS as Device 0 and the FTP as Device 1.

Regards, Denis

Not “ls”,“lsof”. Run “lsof /dev/dsp* /dev/snd/*”, please.

For lsof I get no output.


I got another question. I have a external hardware reverb and connectet it with SPDIF to the digital connectors of my sound device.

I want to use the external hardware as Send Effect for my vocal track. If I add an SEND effect I just see the analogue INs and OUTs of my sound device. Do I have to register the external one to get it working? The strange thing is if I play one track in Ardour I can see some input signal on the external reverb. The sync LED is showing that the external device is synced.

Jack shows me

pcm_capture: capture 1, capture 2
pcm_playback: playback 1, playback 2

Do I have the chance to get the whole thing working?

Regards, Denis

Some news about that topic? I’m still trying to get a working setup with my Fast Track Pro.

Regards, Denis

The Fast Track Pro is like two devices in one box. In qjackctl, you have to select the in- and outputs you want to use. For example: Your on-board sound chip is hw:0, the Fast Track is hw:1. If you want to use output 1 and 2, use hw:1,0 (this configuration has no inputs!). If you want both inputs and output 3 and 4, choose hw:1,1.

Maybe one can make an ALSA config file that puts both hw:1,0 and hw:1,1 in one virtual device…


I got the Fast Track Pro working nicely with Jack/Ardour on Ubuntu Studio. I borrowed one a couple of weeks ago, so unfortunately I can’t provide more details now, but as far as I remember it was pretty much plug&play. It showed up in qjackctl as hw:1 and I was able to record and playback.



I got the recording working again with 44 kHz / 5.8 ms shown in Ardour. Jack shows me 34.2 ms of delay. Could you tell me what’s right and what is wrong? (Jack or Ardour)
The thing is recording vocals with the setup at the moment is nearly impossible using soft monitoring. Under windows using Abelton Live with the same sound device it was no problem using software monitoring but at the moment with Ardour there is so much delay between my real voice and the voice I get through the heads so it is not possible to record anything.

Here is my setup in jack:

Using lower settings I get xruns.

I’m using a lowlatency kernel distributed with Ubuntustudio.

get a realtime kernel. I originally installed ubuntu-studio which came with a low lat kernel because ubuntustudio comes with tons of sound apps out of the box. As soon as the install was done, I actually changed my system quite a lot : installed a realtime kernel (compiled myself, using 2.6.23-rc2) + upgraded quite a few things (basically, switched to gutsy).


I have a very stable system, except for a few ardour crashes (using 2.0.5) due to heavy gui manipulations (it seems to me that crashes occur when I use zoom in/out too fast but sometimes, it also happens just by changing the name of a track). Fortunately, these crashes are rare and everything is recovered except for 2 or 3 few editing actions, not too dramatic.

So you would say it is a problem with the kernel? Why do they have a low latency kernel when I have to compile another one in order to get a working setup? :slight_smile:

My setup at the moment:

Ubuntustudio low lat kernel
e17 window management
Ubuntustudio audio software package
2.6 @ 3.2 Ghz AMD Mobile
1 GB 3200 DDR RAM

Is there a guide how to compile another kernel with Ubuntu and what is the best realtime kernel at the moment?

Regards, Denis


Don’t get me wrong. You can of course install the “linux-rt” package provided by ubuntu. You don’t need to compile it yourself.

Just open synaptic or aptitude and look for “linux-rt”. It will install everything thing you need. Maybe you need to include gutsy rep in your /etc/apt/sources.list, just try it anyway.

I compiled my own kernel because I had some strange behavior with 2.6.22-9-rt provided by ubuntu, I was losing an interrupt exactly every 10mn, which caused jackd to spit out an xrun precisely every 10mn. The vanilla 2.6.23-rc2 kernel, rt’ed with Ingo’s patch, fixed this problem. Don’t ask me the root cause, I have no clue and you may not see this at all yourself (hardware dependent, I’m sure).

I would like to buy M-audio Fast Track USB. But it isn’t on the list of soundcards supported by alsa driver. (http://www.alsa-project.org/main/index.php/Matrix:Vendor-MAudio) But some of you write in this discussion, that it works. So do you think it will work well, or shall I buy rather some another card, is supported (is on the list). I use Fedora Core 6 and the realtime kernel PlanetCCRMArt.
Than you,

It claims to be “usb audio class compliant” so it should just work with the alsa usb-audio drivers.

However it may not have all of the features enabled:

16-bit/48kHz 2 x 4 operation is class-compliant. Driver installation required to access more I/O.

Thank you for your instant answer, Jonathan.
Do you think, there will by ever added a special dirver for Fast Track USB to alsa-project? Fast Track can work in 24bit depth. This wouldn’t work with the general driver, as you say.

There was a patch to get 24bit working which is now included in the ALSA sources, so there are no problems with 24bit mode.

I’m trying to get the Fast Track Pro working as well, and unfortunately I’m very unfamiliar with Linux and JACK. Just downloaded it a few days ago.

Anyway, I’ve followed the above instructions about setting the input/output in qjackctl to hw:1,1 (in fact, I’ve set everything up exactly as in denis_std’s screen shot from last February), and I can record from the front inputs in Ardour just fine.

However, playback seems to be a problem. I’m trying to monitor playback via the FTP’s headphones jack (I haven’t really tried connecting anything to the rear outputs yet, even when recording on my Windows machine…never needed to). I tried this with both positions of the A/B switch on the FTP; one position results in no sound in the headphones at all, while the other results in a highly distorted version of what Ardour is playing back.

The waveforms look pretty normal to me, so I don’t think this extra distortion is actually in the recorded track. Any ideas what might be causing it in the headphone output?