m-audio 1010lt in ubuntu studio 10.04 Lucid Lynx

I have mixing with ardour in ubuntu 10.04 for a few months now with no problems, and after a bit of research I decided on the m-audio delta 1010lt pci interface, as it has been largely reported to be very compatible, despite the lack of official drivers. However I am quite new at routing and am having trouble getting it to record - no problems routing the audio for playback but no signal registers for recording even when I think I’ve got it set up correctly. I have been having a look at the Gnome Alsa mixer but it is a little reluctant to explain itself and I can find no support on how it works - can someone explain this all in simple terms please? I am a bit lost.


I use a 1010LT, admitidly with 9.10, and it works great. The first thing that leaps to mind is the levels in alsamixer. I would use the terminal rather than gui (I think it has a nicer interface) The channels are all rather criptically named but the inputs are the first bunch from left to right and are labelled something like ADC0 to ADC7. Make sure they’re turned up. I’m not actually in front of my own PC now but I will be later so let me know if this is too noddy and I’ll have a look and post my other settings.


That sounds promising. Unfortunately I am also not at my computer (killing time at work) but will be in front of it in about 5 hours to try and make it work. By “terminal” do you mean the command line terminal on the applications menu? How do I access the mixer through this? ADC0 to 7 rings a bell, the channels were marked thus on the gnome mixer. What does it stand for? There were also channels marked DAC or something of that nature.

Yes, I do. Get it up and type alsamixer then it will come up. I should be at home then too although I’m having connection issues so I might not be able to get online.

ADC stands for analogue to digital converter (ie input and as opposed to DAC, digital to analogue converter or output) I’ll try and check back later and see how you’re doing.

Is there some reason you’re using Alsamixer with this device ? It’s better served by the Envy24Control mixer, a much better GUI for the M-Audio devices.



I also took a look at the Envy24Control mixer, and found it similarly baffling. Is its operation similar to the Gnome alsa mixer, as described above?

I’ve also read on other forums that for the best results I should uninstall pulse audio. Is there any truth to this? Not that it has been giving me any problems so far.

If you’re using your computer for general purpose computing (as opposed to strictly audio work), there is no reason to uninstall pulseaudio as long as you’re not encountering any problems. As far as which mixer to use, the envy24control may be a bit much to understand, but is much closer to m-audio’s software in windows and mac. As such, the section of the instruction booklet that comes with the card does a great job of explaining what all the controls are in envy24control (not so much with alsamixer). The added bonus of envy24control is that it has built in meters so you can see when you’re getting a signal on your inputs. The important thing to note, however, is that you’ll need to turn up the corresponding ADC fader for the channel (or channels) you’re trying to record from before you’ll see any metering going on in the monitor section. I would bet that doing so will allow you to get a signal from this card (I didn’t bother to read the manual when I bought mine, and I must have screwed around for an hour before I figured this out).

Okay! So I managed to get it working through the use of envy24control, and recorded a couple of things. However, I have a couple of issues - first, how did I get it to play the live signal through the monitors? And second, why on earth am I picking up stray radio signals, and is there any way of stopping it? It’s really loud!

you can monitor your live signals with the envy24 control utility in the patchbay / router tab. If you would like to monitor the signal on H/W In 1 on H/W out 3, select H/W In 1 on the H/W Out 3 section.

Alternatively you can monitor your signals directly with jack (which is a little bit more flexible) - but there you’ll here the latency of your setting.

Only working with 2 outputs at the moment so I put it through one of those - it comes through nicely. I wonder however if there is any way of mixing it in with the recorded playback, rather than having one on each side?

first of all you can route all the things to a bus and output this bus to the master output (but then everything goes through jack, so there may be a noticeable lag, because of the llatency).

In the ENVY24 control you have a digital mixer - but I have never used it, so I can’t say you anything about it. Maybe using Digital Mixer in the patchbay and mixing the signals in monitor PCM ?

As far as the radio signals go, I would check any of your cables to/from the computer first. An unshielded cable anywhere before your monitor amplifier could cause such a problem. I would check any input cables first: disconnect any cords connected to your inputs one by one and see if the radio noise goes away. If that doesn’t work, try turning the dac controls on envy24control all the way down one by one, and see if that changes anything. If that doesn’t work, try disconnecting the cables running from your computer’s outputs to your amp (or active monitors) while it’s still on. You should be able to find your problem that way. If your monitors still make radio noise with no cables attached, there is most likely a shielding problem in your amp’s inputs (the signal must be leaking in before the amp section for you to hear it at all). If the problem is in one (or more) of your cables, either replace it or make sure that the shielding is still soldered on. If the problem is in the soundcard or your amp, you may need to return them or take them to a repair shop.

Noting, however, that you’ve only noticed this problem since you’ve got your inputs working, I would guess that the problem is probably in an input cable (or perhaps your 1010lt, but that’s less likely). Also, make sure that any inputs you’re not using have their respective adc controls turned all the way down, as these can cause noise (albeit not much if everything’s functioning properly).

I use this card also. You really need to spend the time and learn it properly as it is your main control of the soundcard. I use the envy24ctl to control levels exclusively. Make a link to it on your desktop. I was planning on making a slideshow or movie explaining this as I had been planning on doing this anyway and hopefully can get that done soon.

In short as starting points paying attention to the levels and distortion. This is how mine is set up to take a bunch of inputs for use in ardour and muse:

-Analog Volume Tab :
ADC0/ADC1 (input channel 1/2 left/right stereo pair) set at 146 [experiment to find highest non-distortion level]. Do the same for the other ADC input channels.
DAC0/DAC1 (output channel 1/2 stereo pair) all the way up. Only this channel since you only use one output. The others are set to 000 until you add other outputs.

H/W Out 1 and 2 both set to Digital Mix

-Hardware Settings:
I use 48000 and rate is set to Reset. I don’t use SPDIF

-Monitor PCMs
This depends on if you are using Stereo or Mono inputs. Mine are mostly stereo, so for example PCM Out 1 Left is all the way up (0), PCM Out 1 Right is muted, PCM Out 2 Left is muted, PCM Out 2 Right is all the way up (0). See the pattern for Stereo… Mono inputs are easier to control. A screenshot would be useful here.

-Monitor Inputs
Use the same pattern as the Monitor PCMs

Finally, have stuff playing on various inputs and mess around with levels until you get them right. The most important are the Analog ADC inputs since you can easily clip and distort the signal if these are too high. Go as high as you can without distortion.

I’ve never heard radio interference before. Like the previous post says, unlikely to be the card so start experimenting to find out which amp or connection.

Now of course you will need to figure out how to get ardour to use these…

Hope this helps. Geoff

I am a new Ubuntu user, am trying to get the M-audio delta 1010lt to work since about a week but still no results, I have disabled the onboard sound card

lspci | grep -i audio
01:09.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)

01:09.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
Subsystem: VIA Technologies Inc. M-Audio Delta 1010LT
Flags: bus master, medium devsel, latency 32, IRQ 17
I/O ports at bc00 [size=32]
I/O ports at b800 [size=16]
I/O ports at b400 [size=16]
I/O ports at b000 [size=64]
Kernel driver in use: ICE1712
Kernel modules: snd-ice1712

Please help !!

@Pritam: you’ve provided no information at all about whatever problem(s) you are having.