lv2 plugin not recognized...


Ardour doesn’t recognize my lv2 plugin under UbuntuStudio 12.04. What I don’t understand is that evrything was worklng perfectly last week while I was using Ubuntu 12.04. Yesterday I decided to change my disto to UbuntuStudio and since then my lv2 plugins build fine but they are no longer recognized by Arbour 2.8.12 (64 bits). Any idea ?

I’m new to Linux so don’t take anything for granted with me.


Ardour doesn't recognize my lv2 plugin under UbuntuStudio 12.04.

Which plugin?

My own ones.

Plugins can fail to show up for many reasons, I guess its difficult to know what might be wrong without knowing more about the actual plugin. Is there any terminal (console) or debug output from ardour (either when starting, or (re)scanning for plugins etc)?

Are they installed to the correct location, do they have the correct permissions, are the .ttl files correct? (just a few of the many things that might be wrong)

What is bugging me is that when I was using Ubuntu 12.04 everything was working fine. My plugins were showing up and working in Ardour. So, I suppose that the .ttl and the lnstallation path were correct.

My problems started when I have migrated to Ubuntustudio 12.04. I have watched the content of usr/lib/lv2 and my plugins are there with the other ones installed during the UbuntuStudio installation.

You have talked about plugin rescanning… how do you do that ? I told you I’m a linux and Ardour newbie…

Thanks for your time

In the plugin manager, click ‘Refresh’ to rescan for plugins.

To access the plugin manager (in A2) right click in either the pre or post fader insert areas (The black boxes - wouldn’t it be nice if these were actually labelled as plugin insert points? - above or below the fader in a mixer channel) and select:

New Plugin->Plugin Manager

I suggest running ardour from the command line and / or as a debug build, there is sometimes some useful info output when the plugins are (or not) discovered.

If the plugins don’t show up in the menu, the most likely cause is that either the plugin is in the wrong location or the .ttl file is not being correctly recognised / interpreted (a plugin can show up in the menu even if the binary is completely broken).

I’ve no idea what LV2 libraries your different ardour builds (e.g. the one in Ubuntu 12.04 vs the one in Ubuntu Studio) were compiled against, but don’t assume the .ttl file is correct because it once worked. I’ve experienced problems due to more strict syntax checking in later LV2 libraries which caused a previously working .ttl file to fail

You might also try putting the plugin in /usr/lib64/lv2 (as you say you are on 64Bits) - perhaps /usr/lib/lv2 is now not searched on 64Bit? (I really hope /usr/lib/lv2 is still searched or it would cause all kinds of annoying things to happen)
/usr/lib/lv2 works for me on my Ubuntu 10.04LTS 64Bit install but I’ve just noticed that /usr/lib is symlinked to /usr/lib64 (pure speculation again, but perhaps this symlink is missing on UbuntuStudio or perhaps things are arranged differently - it seems the days when there was anything like a standard structure between distros are disappearing rapidly)

I have erased and rewrote the .ttl files and it works now. I don’t know exactly what was the problem but it was related to the .ttl files.
Thanks linuxdsp.