LV2 plugin GUI won't instantiate

I’m new to Linux & to Ardour. I’m using Ardour 4.7 on Fedora 23 with a RT kernel from Planet CCRMA

I’ve installed LV2 and some plugins - notably EQ10Q. I can select them from the mixer strip and they show up OK there. But no controls show up & I get the message:

[ERROR]: failed to instantiate LV2 GUI

I have no idea why, and can’t find any help via Google. Any help would be very gratefully received.

Which gcc was Ardour 5.12 64 bit Linux built with ? I’m having this exact problem on Manjaro with EQ10Q built with the default gcc 7.2.0.

Ok, found a workaround. The eq10q developer is aware of the problem and offers his own binary installer that uses Ardour compatible precompiled libraries (

Done and EQ10Q gui works again :slight_smile:

1 Like

Saved too fast, here is the cleaned up procedure:

Check Menu > Help > About > Config and see if “LV2 UI embedding: True”, if so, the most likely cause for this is a mismatch gcc4/gcc5 (ardour was compiled with one, eq10q with the other).

1 Like

Thank you so much @mhartzel! Worked for me on Ardour 5.12 on Linux Mint 18.2.

Hey Robin,
I have the same problem with the new update on Manjaro.
So i can not use any lv2 plugin anymore, because of the error ‘2022-08-18T09:27:09 [ERROR]: failed to instantiate LV2 GUI’
In the Help>About>Cofig Lv2 embedding: True.
A week ago every plugin worked perfectly, now none.
The output of gcc --version is gcc (GCC) 12.1.1 20220730
What can i do?

I’ve also encountered the problem some days ago on Manjaro.

Turns out to be the suil package update. I was running Ardour from the command line and got suil error: Failed to open module /usr/local/lib/suil-0/ (/usr/local/lib/suil-0/ cannot open shared object file: No such file or directory)

On the Arch bug tracker there is a thread about this specifically:

It would seem it was quickly fixed in version suil 0.10.16-2 and should be available in the arch linux repository. Manjaro tends to be a little slower at updating their repositories and still have (at the time of writing) suil 0.10.16-1 which is problematic

What I did on Manjaro in the meantime is downgrade to the previous version that worked which was in the package cache and the plugin GUI work just fine now:
sudo pacman -U file:///var/cache/pacman/pkg/suil-0.10.12-2-x86_64.pkg.tar.zst

When you perform another system update, make sure that suil doesn’t update to 0.10.12-1

From the bug tracker issue, I’m guessing there is a message directed towards the developers in terms of the GTK2 dependency, which is now EOL:

It’s very unfortunate that ardour’s upstream is not working at all on getting rid of the gtk2 dependency. This way ardour will eventually be removed from the repositories and also require a substantial build overhead in the AUR (e.g. custom suil version), making it disappear into obscurity (aka. manual website downloads only).

Is this foreseeable to remove this dependency in future versions of ardour?

Short answer:


Thank you.
I removed the last system update, did a new update without the suil and everything worked again.
Of course this is a temporary solution, on the next update i then have to exclude the suil again, and i don’t know if that is a good idea in the long term.
Best regards

Glad I could help!
It shouldn’t be too long before suil-0.10.16-2 shows up in the manjaro repository given it is already in the Arch repository. That version should fix the lv2 gui issue. I’d say give it maybe a week or so and it should be in the update. When you update, just look at the package version it will update to.