LSP Room builder and AMDGPU

I’m running Ubuntu Studio 22.04 on a Dell desktop, with and AMDGPU. I’m using the stock Ubuntu driver for the GPU. I want to use the LSP Room Builder plugin. When I select a room from the choices available in the plugin, I do not see the room. I also do no see either the source or the microphones. The room box remains completely empty. If I make some choices and run the room builder, I do get an output; however, I would like to modify the placement of the various contributors which is difficult if I can’t see them.

I also tried the room builder on a 2013 iMac running Ubuntu Studio; on this computer, everything is visible. This suggests to me that there is some issue with the Dell setup.

Could the AMDGPU driver be the issue? Any other suggestions as to how to see the room etc in the room builder plugin>

Not using a GPU here, but just did a little test, and removed the liblsp* items from my /usr/lib/ directory, and the room box disappears. I put them back (and I have the lv2 plugins installed in my ~/.lv2/ directory), and it works again. Do you have those libs in the right place?

liblsp-r3d-glx-lib-1.0.9.a liblsp-r3d-glx-lib.a

I looked on mu iMac where the room builder works, and I can’t see the liblsp-r3d* items in the /usr/lib directory. I tried adding all four to the /usr/lib directory as a subdirectory, but it did not work. I will add them one by one and see what happens. Thanks for the idea.

I am on Ubuntu Studio 22.10 with Nvidia Geforce RTX 2070 super graphics card and Nvidia drivers. It seems to work here.

Thanks for getting me to think and look. It turns out that I had two versions of the LSP plugins installed, and I’m guessing that caused a conflict. I removed one version, and I can see the rooms now.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.