LOUD beeps and noisy ardour

i’ve been trying out ardour today. Looks like a very powerful piece of software. However i’ve come across a few things that would prevent me from using it in my studio…

First thing is that i heard static in the output. I’ve loaded up 4 stereo wav files as tracks. When i mute them all, i don’t heard any static. The more i unmute, the more static i hear. This is with ardour 0.99.3.

I haven’t been able to load more than 30 or 32 stereo tracks, after which i get this message in console.log :
no ports available!
cannot deliver port registration request
terminate called after throwing an instance of ‘ARDOUR::AudioEngine::PortRegistrationFailure’
what(): failed port registration
jack_client_resume: send error for (ipc/send) invalid destination port

I wasn’t attempting to play the thing, just load up lots of tracks (stereo ones).

Using the 2.0beta11 version i’ve came across the static noise issue (i think). I’m afraid of using the beta again. Sometimes it just pulls the loudest beeps to ever come of my macbook pro. It scared everyone in the house. I don’t hear the loud beep when i turn off the volume. I hear the loud beep even when i’m using a very low volume. I’m using internal speakers when just testing things.

Any help is appreciated :slight_smile:

Ardour does not produce any extra static to the signal. It plays whatever is on the tracks precisely. Regarding the error you get, you need to change the maximum port count in jack.

The beeps need to be looked into though. What sound card are you using on your computer?

Thanks for the tip for jack port count. I didn’t know about that but will look into it.

I am using the onboard soundcard of my macbook pro. It emits the same beep as when you do a firmware update. I suppose it is because i was running too many tracks at once as a test. It’s just that the beep is so loud.

I was getting the static even when not playing anything. Just had 4 tracks loaded and i heard some static. Could it be that some sort of monitor input is activated ?
Because when i muted the tracks, the static was going away.

If i can fix those issues, i’m sold to ardour. It does everything i need (and more).

a) you’re running out of JACK ports. When you start JACK, you need to increase the -p nports parameter. If you use qjackctl (recommended), it has a nice setup dialog to let you specify how many ports you want. Ports are cheap - ask for more. Ardour2 behaves more politely when this happens, I believe.

b) the static is probably caused by software monitoring. Depending on the audio interface you are using, you may want to disable this. In Ardour2, go to the options menu, Select “Monitoring” and choose “External Monitoring” from the list that appears.

c) the beeps are a mystery. without hearing them or knowing when they occur, its very hard to comment.

Thanks again for taking the time to answer my questions.

a) I am using jackosx, i will have to search a bit to change the number of ports. There are several parameters linked to ports in the gui it has. I will read up on the -p option to see what it relates to in the gui.

b) Will try this when i get home as i do not need to monitor the inputs when just loading up wav files.

c) This is quite a mystery to me. Searched the whole web for macbook pros emitting loud beeps but didn’t find much. Seems like the equivalent of pc speaker beeps only much louder. You can hear this beep when you update the firmware of your computer. Heard it once too when messing around with puredata. (at 3am it makes for a very embarassing moment)

I was trying to push the limits of ardour2 to see how my computer would handle lots of tracks. You know, just to have an idea of what is possible.

I loaded about 30 stereo wav files as tracks. Then i pressed play. It started playing fine then the dreaded beep scared everyone around the place. I was using the onboard soundcard thru the built-in speakers. Volume was quite quiet as i tend to try things out at a really low volume just in case…

After this dreaded beep, the music started again. I then clicked on stop and put the cursor at the beginning of the “song”. Pressed play again and it beeped immediately. I could try with just 2-3 stereo tracks to see what happens. Maybe it’s when i’m asking too much from the computer…

I finally had some time for testing when it wasn’t too late. The scary beeps of death are still there.

I raised the number of ports to 4096, the maximum the interface let me set in jackosx.

i set monitoring to external monitoring

I loaded up about 11 stereo tracks, 44khz 16bit wav files. Pressed play and it beeped very loudly. I then went into the jack menu of ardour 2 and set latency to maximum setting. It seemed all fine for 10 seconds, then i pressed stop. Went back to the beginning of the track and pressed play, loud beeps of death again.

Could it be that the software is using some sort of beep function to indicate that it can’t keep up ? Perhaps the beeper on my macbook pro is just crazy loud for some reason…

I didn’t see anything in the console.log and system.log files. The only thing written in the console.log is “actually writing state”.

One thing that comes to my mind is… Is it possible that the software is sometimes enabling the mic input of my mac ? The mic is supposedly quite near to the left speaker so if it just switches on the mic input for a second, i suppose feedback would happen…

I’m stumped, don’t know what to do. Ardour2 does pretty much all i could ever need to record my music.


Is the click enabled - could the beeps be the click?

Would it be possible for you to record the beeps with a mic and post them for us to analyze?