Lost my session

I’m desperate ! I have just finished a 30 mn radio program and Ardour version 6.9.0 bugged, When I restarted it, no possibility to get the work I was on.
I have a last week saved session, but made 2 days of work since.
The error message says (translated from french)
Session “/home/tastybud/Donnees/1 CREATION/ARDOUR CREATION/amusa_boca (cliché amusa_boca)” did not charge correctly. Impossible to initialize the session_engine : session state corrupt.
—ERROR: Impossible to define the state of session from XML
ERROR: Session : impossible to create reading list from XML description.
ERROR: reading list : can’t create a region from XML n
ERROR: Session : XMLNode describing AudioRegion refer to an unknown source id =1092832

Any idea ? I tried the bak file but did the same. what’s about history ?
Thx a lot !!

1 Like

Oh dear, that is appalling.

Have you perhaps used Session > Cleanup > … in Ardour 6?

If so, the good news is that the session can be recovered.

Please upload the .ardour session file to some place (google-drive, pastebin.com, …) and I’ll see if I can fix it.

1 Like

No, did not use the clean-up tool…
Here’s the file, you can upload here (DropChaprilOrg)

1 Like

OK, looks something went wrong with Region Compounds.

I’ll investigate later but first: here is a fixed session: http://robin.linuxaudio.org/tmp/amusa_boca.ardour

The problem was the Jingle Track (which is now empty). There was only a region “jingle_C1T_22_23” (at 49 seconds into the session). The region references a source which is no longer available. – I hope you can reconstruct it if needed.

PS. If you have already downloaded the file, get it again. I accidentally uploaded the broken version at first.

Summary looks like:


Hum ! Thx a lot, you saved my night :slight_smile:
For the jingle region, no pb I’ve got it saved elsewhere.
As a matter of fact, I had done some deleting of old jingles at one moment, and certainly I deleted the one which was in use… that’s when it bugged.

1 Like

Well, I am either directly or indirectly responsible that Arodur manages to break sessions in the first place. This should not have happened, so I’m glad it worked out for you.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.