Looping tempo loss

Hi all of you.
Since I decided to give a look at Ardour5 I have always found this strange behaviour wich is causing loops to loose a lot of msec resulting in a consistant delay that basically makes the loop feature almost useless and overdubbing nearly impossible.
I have never experienced nothing similar to previous version such 3.5 and i tried the 5 version on various distro having exactly the same problem.
Can someone give me some general overwiew wheter it is a bug or not?

You haven’t really described the problem in enough detail for me (and likely for anyone else) to comment. Are you using seamless looping (the default)? Are you synced to any external transport position?

Thanks fo the reply. Here is what I mean:
Needing loops to be played in sync with the timing of the loop station, i record and keep track of the timing in my ardour session, whose tempos are also in sync with delays of the pedal fx.
Normally I do and I have done that with Ardour3.5 and it plays in sync for about some decade (jocking) before loosing the sync with the digital loop station but with Ardour5.9 there is no chance to do that, loops are just out of sync after a bar on the very same track and metro. I tried this with jessie and testing. I’m still using Avlinux 6.04 (which is great) but it still has this delay at he end and i tried with other distro, all of them with and without a rt-kernel.
Look yourself here below


Well this is a demo copy but i tried also those from repos and still the delay remain.
I just would like to know if it is a problem from the program itself, unless I will stay with 3.5 wich is great but the new midi handlig in 5 is greater, soooo…

And to answer directly to your questions:
-No I’m not using the green jack button while plaiyng
-Yes I’m using sync with metronome and not, while rolling jack or not and it doesn’t change the delay is still the same