Loop recording issue in Ardour 6

I mentioned this in my other thread, but it seems to have been missed and it’s actually way more serious than the original issue:

I hit the loop button in 6.0 and then hit the record button mid-loop and proceeded to lay down half a dozen odd takes while looping. When I am done, all my takes are transposed in time, by about the offset between the start of the loop and the moment I pressed the record button.

(works fine if I hit the record button first, then hit the loop button.)

I tried reproducing this again this morning.

When I hit record in the first half of the loop, it worked fine. But when I hit record in the second half of the loop I got an odd error message (“cannot write to disk fast enough” or something), and I got the behaviour I described above. (I didn’t get this error message when it happened yesterday.)

It’s a bit weird, but there’s definitely something not right.

The forum is no place to file bug reports. It’s entirely unsuitable to keep track of things and they’re likely going to be ignored, missed or forgotten.

Please open a ticket at tracker.ardour.org. Thanks.