Linuxsampler and stuck notes

Hi,

I’m following this tutorial on setting up linuxsampler in ardour.

When I hit a note in the piano in the track, the note sticks… with this being repeatedly displayed in the console. (launched from command line) Im doing the same thing as 4:13 in the video.

0x955df92 note 71/0 was already on, now at 5

and it takes many clicks on the “!” midi panic to stop it.

my version of ardour is
Ardour 3.3 (built from revision 3.3-173-g868112b)

This a bug that needs reported? or something I’m doing wrong?

thanks

also, if I draw notes in a midi section… play back is as expected… no stuck notes. :slight_smile:

and playback is quiet when notes are not being played. but… without any playback occurring… press stop - there is noise. even shows up in the master bus. with the output bouncing up and down…

which version of ardour are you using? i have found v3.3 to be unusable with midi too unstable. Try v3.0 which seems to be stable enough to get stuff done.

It may not be ardour it could be linux sampler, i havnt tried it again but i found it to be unstable when using muse and would just crash.

Ardour version for today is Ardour 3.3 (built from revision 3.3-178-g1421a34)
just compiled it this morning. No other midi devices. even turned off BCF2000.

ok. this is kind of interesting… I imported a midi file from here - the flute solo version. and this is the only track.
http://imslp.org/wiki/Piano_Sonata_No.11_in_A_major,K.331/300i(Mozart,_Wolfgang_Amadeus)

ok, have it being played back with linuxsampler. all sounds great.
and I expanded the display of the track to show the piano keyboard. As the midi file is being played, I can click on piano keys and hear the sound, no issues. the note plays and stops. but…

Now, if I stop the playback. I hear static. and it gets displayed in the master mixer level meter. as soon as I start playing the file… the static goes away.

And, when playback is stopped, if I play a key on the piano in the track, the note gets stuck… it stays that way until I start play back of the midi file. or hit the MIDI panic “!” … maybe at least 17 times for it to register.

This seems to be a bug. I guess report it in Mantis?

LeatusPenguin - you were right… I had launched a2jmidid before starting ardour. I disconnected its default setting… thanks :slight_smile: