Linux setup of Zoom R8 as interface

Wondering if this can be done.

I can record and playback using the computer input: 4 conductor TRRS.

Does anyone know how to set up a Zoom R8 as the interface (USB Connection)?

Connect the R8 USB to the PC and select AUDIO I/F on the R8,
When you start Ardour6, in the Audio setup panel, select Audio system ALSA and the R8 should appear in the dropdowns for input and output device.

Optionally, to (also) use the R8 as a controller: In the Preferences > Control Surfaces select Mackie.
Select “Show Protocol Settings” and assign the R8 to Surface sends / receives via.

Thank you for that…seems like I’m half-way there.

In the Audio Setup for a new project, with ALSA the only input device offered is HDA intel DCH, however, on the Zoom 8, my studio mic is moving the needle, and the needle is moving on the Ardour5 mixer on the computer.

I also switched to the instrument line and was able to record to Ardour an audio track from the acoustic guitar.

Now on play back, I can’t hear anything, neither through the headphone jack on the R8 or through the computer (with or without headphones).

Playback help please.

Ardour 5.x is about 3 years old at this point. Ardour 6.5 is out, Ardorur 6.6 will be released soon.

First suggestion would be to use a current version of Ardour.

1 Like

with ALSA the only input device offered is HDA intel DCH

Are you sure you did connect the R8 via USB first, and selected its Audio I/F function?

yes I did, but not sure about if I need a new project or not?

I’m going to restart the computer and try once more.Z

Computer on
Zoom R8 plugged in with USB
Zoom R8 power switch on
Auto Punch I/O depressed
Launch Ardour 5
New Session
ALSA: Input and output devices HDA intel DCH

The result after above steps:

The microphone and guitar will move the needle on the R8 but is not the IO device for the computer, as I have a switch on my microphone, and when I switch off, the computer microphone must still be the input method.

Ok, I am closer than I’ve ever been.

I located the manual with the Zoom R8 and they say to activate as a USB interface:

press
but a driver is required to be downloaded from www.zoom.co.jp

and they say to activate as a USB interface

That’s what I’ve been telling all the time: connect the R8 via USB first, and select its Audio I/F function. Do not power on the R8, connecting via USB will automatically start it and allow you to choose between Audio I/F and Card Reader.

For Linux you do not need a driver. It works out of the box.

While this all works with Ardour5 you really should consider upgrading to Ardour6.

thank you on the USB hint.

I went into Linux, while the USB was on, and pavucontrol shows the Zoom as readable and active through the studio microphone, as when I switch the mic off, the pavucontrol bar does not move…so I’m getting from Zoom across the USB cable to the computer.

Ardour knows that the Zoom device is available because that choice is available when setting up a new session.

There is one piece of the puzzle missing…

Not sure what I’ve done, but I started with an upgrade on the firmware to 1.02.

Then pressed the USB button, which offered “Setting - Continue.”

I selected setting and wheeled and saw an option to “Reset.” I executed a reset.

Then when creating a session, I added a Stereo Track.

A guitar is in input 1 and a microphone is in input 2. Both input devices “move the needle.”

I armed the track and master and recorded simultaneously - the result was a stereo track which had a audio wave in each side.

Still nothing on playback - not out through the R8 headphones, or the computer speakers.

OK. let’s follow the signal path…

  1. Does the master-bus meter show a signal?
  2. What is master-out connected to?

  1. What output device is chosen in Menu > Window > Audio/MIDI Setup?

  2. Is there any gain-staging on the output device? Check hardware mixer:
    4a. Check alsamixer (for software controlled mixer)
    4b. Check physical gain knobs (amp, speakers) if applicable.

Master Bus does NOT show a signal.

Master out not connected to anything, but when I green-light on the grid, nothing changes.

Zoom is selected as the output device in Audio/Midi setup.

Check hardware mixer? Not sure.

Then you need to check your routing within Ardour, confirm that the tracks are routed to your master bus?

  Seablade

success, thanks to everyone for getting me to the end.