linux-rt in karmic

did they finally get it right?

I’ve been trying the ubuntu realtime kernels for a long time and they never workerd (for me) or when they did they didn’t actually allow tight realtime in jack.

At last, I managed to run the vendor-provided realtime kernel and it’s amazing, no xruns at 2.6ms latency. I can sing a duet with myself using Ardour software monitoring. The only “hacking” you need to do is related to /etc/security/limits.conf, as explained in many places in this forum and elsewhere.

Oh yes, the trouble I had at first was that X didn’t work in the realtime kernel with the proprietary nvidia graphics drivers, but the envyng script managed to sort that out.
I had to tart the linux-rt kernel in “recovery mode”, and run “envyng -t” and install the proprietary graphics drivers.
I can now use the realtime kernel for everything (including playing “world of goo” which won’t work with the plain graphics driver).

Just thought I’d share this because it makes me happy…

congrats :slight_smile:

for me, what makes me feel better, is that I can use the recent kernel (2.6.31 series) without the RT patch at all latencies, using jack2 in synchronous mode (jackd -S).
Even though it was a routine to compile the kernel, etc, I grew a bit tired of it due to the recent stability issues (2.6.26 to 2.6.29). Using the vanilla kernel is just nice :slight_smile:


I totally agree. I was using Ubuntu Studio and Ubuntu with the Studio packages installed, which seems to be more stable. But I always had problems with the rt kernel. Using the rt Kernel made the system really unstable and my intel quad core wasnt as good supported is i would love to. I also had problems with my nvidia grafix card.

I recently updated to ubuntu 9.10 and the new ubuntustudio packages with the new rt kernel and and now everything works flawlessly. It takes use of all 4 processors no more crashes and freezing and perfect speed.

Its just heartwarming to see good things (like JACK, Ardour, Hydrogen or Ubuntu) can get even better.
Now I’m just waiting for Ardour3 and MIDI, would be a very nice gift for Christmas dont you think?

Wow, it seems to be time to try the rt Kernel again. My previous adventures with it had been horrible, let’s see if it really works now :slight_smile:

I´m still getting random lockups using Freebob in 9.10 linux-rt. Any suggestions? The generic kernel works (somehow) with FFADO, but jack tends to crash a lot…


I a karmic ubuntu studio install on my old desktop. it is the standard onboard sound I use on that machine but I can hear that the rt-kernel is better than it was on the hardy release. I get some echo on the bass when I record but I think it is because the c-media onboard soundcard is not really fit to do audio recording.

I will be getting a new sound card next month and use two desktops for music and then when I can afford it I will want a laptop with a good sound card for it dedicated to mixing down from the hard disk recorder and using ardour to do the mixing . I hope to use 64studio but having tried karmic I could use that as well.


I am using ubuntu 9.10 with the ubuntu studio packages installed. Got a presonus firepod working working with jack and ffado. No crashes and almost no xruns so far. I never had problems with jack so far. Maybe Paul could help here. But i think there might be a ubuntu or realtime kernel problem.

Did you try another kernel?

Hi there!

Interesting reading I’d say !

Based on what you are saying, I think I’ll go for a dual boot system for my
workstation. Preparing it for a ‘stable’ release (typically 64 studio 3.0) and
‘flavour of the month’ type of system (typically karmic + Ubuntu Studio repos).

Has anyone tried this method
awaiting a new 64studio releaase ???

Thanks for your input folks !!!

I´ve got the firepod too. What specific Ubuntustudio packages are you talking about?
I´ve got the following packages on my system:

and some ubuntustudio eyecandy (not using these though…)

When using the generic kernel with ffado, it runs (somehow) but it´s not reliable enough, because jack just quits from time to tome. RT kernel gives me hard system lockups… Could it be my chipset?


00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03) 00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03) 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02) 00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02) 00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02) 00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02) 00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02) 00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02) 00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02) 00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02) 00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02) 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2) 00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02) 00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02) 00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02) 01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce Go 7600] (rev a1) 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02) 04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01) 06:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev c0) 06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10) 06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01) 06:04.2 SD Host controller: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01) 06:04.4 FLASH memory: ENE Technology Inc SD/MMC Card Reader Controller (rev 01) Again, it works perfectly with 64studio 3.0beta. Could it help to rebuild jack/ffado/freebob/firewire from most recent tarball/svn? Could it be my 64bit karmic install?

What other kernel are you talking about?

I do believe that Karmic did get it right. I’ve been severely critical of Ubuntu, but my upgrade to 9.10 has given me good performnce with the stock non-rt kernel (xruns occur about once every two hours) and excellent performance with the stock rt kernel (no xruns at all). Hardware is an HP G60 notebook, I’m testing with its notorious HDA chipset at 11 msecs latency. I’ll work on lowering that figure, but it’s satisfactory for the moment.

I had to add myself to the audio group and I had to fix a problem with grub. After those repairs I was astonished to note that Karmic correctly identifies my wireless, correctly set up the nVidia proprietary driver, and handles Pulseaudio without my intervention. Not bad, not bad at all. Looks like I’m going to have to write a new review. :slight_smile:


Hi Dave,

I think that these issues:

1- /etc/security/limits.conf (or unix group conf for SCHED_FF/RR access)
2- grub2

are big showstoppers.

2- may make your system unbootable
1- is paramount for a reliable performance (RT patched kernel or not).

I would understand that plain ubuntu does not come with this setup. However, U.S (audio-centric installation) should since the underlying audio processing / handling is based on a server and apps that are RT capable.

So why is this issue still around ?

This is OT though. But since you’re about to write something nice about Karmic, I just wanted to express my opinion : because the previous U.S iterations were a nogo, Karmic feels like great, and to me, this is not the case because of these 2 issues above. And IIRC, jack is now defaulting to RT mode. Think about new users that start jackd without the -R option (not knowing dick about these things) and getting the infamous “not RT capable, giving up” or whatever it is and not understanding what the hell is going on.

Or is there a logic behind this lack of SCHED_FF access by default in U.S. ?
Or am I mistaken in my understanding of your installation issues ? I heard somewhere else that some folks had flawless performance OOB. Were your issues a special case ?

In my desktop PC jackd -R works OOTB with US 9.10
‘ulimit -r’ gives 99.
‘ulimit -l’ gives 64 though. I had to add the memlock unlimited line to /etc/security/limits.conf.
linux-rt is installed.
This is a fresh install, I am not upgrading.

All in all, I am very happy with it. Gnome works flawlessly. Ardour is 2.8.2.

Cheers, Pablo

Hi thorgal,

I agree that those issues are deadly, but they’re also easily fixed. Btw, I’m not exactly running UStudio. I originally installed plain-vanilla Ubuntu 9.04 and added the UStudio audio/video packages. I noted in my article on Jaunty that the failure to prepare limits.conf was a strange oversight in a distro that intends to provide an environment for audio production, but I guess the UStudio devs don’t read my articles.

I’m far more amenable to Karmic than I was towards Jaunty. I had troubles then with wireless, hal polling, limits.conf, power control, the rt kernel, my touchpad, pulseaudio, and more. By comparison Karmic’s been a breeze, with attention needed only by limits.conf and the grub problem (didn’t add the new kernels to the menu). So, yes, I think there’s been some improvement at fundamental levels, though work still remains.

Btw, my issues with Jaunty were definitely not special. The Ubuntu forums were/are loaded with complaints about the system, many of which echoed my concerns.