Linux & Ardour version for EQ10Q V2.1

Hi I want to try the last release of EQ10Q plugin but when I try to open the GUI I get an error message: “ERROR: LV2 GUI cannot be loaded” .
I try Installing Ardour 5 (gcc4 & gcc5) 64 bits version in Ubuntu 16.04.1 LTS but didn’t work so What version of Linux and Ardour you recomend me to use this plugin?

Hi, Ubuntu 14 and 16 are supported, actually I’ve tested EQ10Q on them. However, if you got Ardour from their website then EQ10Q plugins will not load the GUI due a library version mismatch. Ardour.org binaries are providing a quite old versions of some libraries. Such versions are hard to found in modern Linux distributions using gcc5 so Ardour binaries may result not compatible with plugins using those libs.
Ideally, plugins must be designed in a way that them are self-contained and the external used libraries are kept to the minimum. But the linux software distribution model based on source-code or distribution packages overcomes such issue with package dependencies. So, I think that the best way to redistribute software is using the Linux distributions package architectures. Nevertheless, Ardour project is a bit against this redistribution model because in some occasion some distribution broke the program in some way. I’m not 100% agree to avoid the main linux distribution model because it is the best way to assure compatibility but this is what is happening now. In my opinion, Ardour should distribute binaries compiled using modern libraries to provide a wider compatibility with packages compiled in a modern Linux.

I’m designing the next major version of EQ10Q plugins using another graphic toolkit which will provide a self-contained model to assure a great compatibility. But this will take a long time and probably will be a whole new project based on EQ10Q code. Since Ardour is a major host for EQ10Q, I’ve considered all of this and in hopefully in 2 weeks I will release the version 2.2 which will provided binaries ready to run in Ardour binaries. Such binaries of EQ10Q were build using a carefully selected versions of libraries to provide a wide compatibility. I already have a working binary package of EQ10Q plugins, but it is in testing stage. If someone is interested in testing it, please provide your email address and I’ll send you a copy. I’ll be very happy to hear some feedback before the release date.

1 Like

That is great news!

I’m super excited for the next major version of EQ10Q. Was already my favourite EQ and Compressor and I thought the last version was an awesome improvement!

@sapista: I have Ardour 5.4 installed downloaded from website and EQ10Q 2.1 and I don’t get any gui. Is this because Ardour is built with other GCC version?

@dsreyes1014: Your issue is not related with gcc versions (as long you are using ardour complied with the same gcc version used to build eq10q). The issue is related with the gtkmm libraries provided by ardour downloaded from official website. In fact, ardour.org is currently providing some really-outdated libraries for example libsigc++ (used by gtkmm and eq10q gui). Those old libs are difficult (or impossible) to found in modern Linux distributions using gcc5. Consequently, your builds of eq10q gui are prone to fail when loaded on ardour obtained from ardour.org. In order to provide a workaround of that issue I’m preparing eq10q pre-compiled binaries using a carefully selected libraries versions to be compatible with both ardour from website and other lv2 hosts included in your distro.

Anyone who is interested in testing such eq10q binaries, please email me at: sapista@users.sourceforge.net and give me your email address in the mail contents and I’ll be happy to provide a beta version of a eq10q installer. Please be patient because I’m still working on this binaries but I’ll be able to provide them in a few days.

@sapista: So a little bit of a workaround for now. I just installed Ardour from the Gentoo distro but it’s still using the old 5.3 ebuild. I’ll just wait for either Gentoo’s updated 5.4 ebuild or your precompiled EQ10Q.

You can bump the ebuild version easily enough yourself.

Looking forward to these binaries being available, I love these plugins.

I’ve had some problems with my sourceforge mail so to simplify the testing of eq10q binaries you can download the installer from here:

https://drive.google.com/open?id=0ByLVj1kYKuFSc29WVklxT3BMZWM

It is just a .run package, so first give it execution permissions (chmod +x eq10q_rc2.2_installer.run) and then run it (./eq10q_rc2.2_installer.run). The installer will detect the target system architecture and gcc version and automatically install the appropriate binary files.

Your feedback is welcome, so if you try it let me know your opinion and problems using this forum or eq10q discussion:
https://sourceforge.net/p/eq10q/discussion/1071651/

@dsreyes: Yes sure, if you use a self-complied version of ardour together with a self-compiled version of eq10q it should work as long the libs used in the build process are the same for both programs. In other hand, if you are in any Linux distro that provides a quite new version of Ardour and you compile eq10q it should also work but will provably fail for ardour’s website binaries. Please, can you check out my binaries on your Gentoo machine?

@sapista: new plugins worked, but I experienced a problem I already had before with them. I filed a bug on Sourceforge (#15 in 2.1 bugs) about that before. Now it happens again with Ardour 5.4.

Hello, many thanks, eq10q rc2.2 worked with Ardour 5.4.255.

sapista: your script worked on a machine I was testing but with Ardour 5.5 it won’t even see your plugins for some on my home machine. I’m not sure why. I’ve scanned for plugins but still won’t show.

@dsreyes1014: I’ve just tested Ardour 5.5 on a 64 bits Linux using gcc5 version. EQ10Q plugins installed using my script are running fine here. Please, can you provide more information about your system? Also check that you don’t have various installations of eq10q in different places like ~/.lv2 and /usr/local/lib/lv2.

@sapista: It was the ebuild I was using on my Gentoo system that was causing Ardour to not see EQ10Q for some reason. I downloaded and installed straight from ardour.org and it works fine here. Sorry about that.

@sapista: I have an update, the official Ardour update on Gentoo (Ardour-5.5) still doesn’t see eq10q in /usr/lib/lv2.
Ardour is saying:
WARNING: Ignoring invalid LV2 plugin http://eq10q.sourceforge.net/

Could this be a .ttl problem? LV2 libs recently became more strict and won’t load a plugin with .ttl errors.

jrigg: Could be. When using the downloaded binary from ardour.org and using the script sapista posted from his google/drive it works but not when building from source with Gentoo.

@dsreyes1014: What does sord_validate say about the version which doesn’t load?

@jrigg: Not familiar with sord_validate. Would it be something like $ sord_validate eq10q?