Linux and ALSA

Discussion surrounding various Linux distributions, ALSA Errors and how to solve them

This is the solution I got from the IRC channel:

<+abrock> it seems your main soundcard (hw:PCH,0) is used by some other program
[15:11] <+Guest81343> OK and how do I change that situation?
[15:12] <+abrock> sudo fuser -v /dev/snd/pcmC0D0p
[15:12] <+abrock> this should show the process using the soundcard
[15:13] <+Guest81343> ok give a sec to try it
[15:13] <+abrock> this should kill the process directly: sudo fuser -k /dev/snd/pcmC0D0p
[15:14] <+Guest81343> ok I get: 2025 F…m pulseaudio
[15:14] <+abrock> try pulseaudio -k
[15:14] <+abrock> as normal user
[15:14] <+Guest81343> ok
[15:16] <+Guest81343> great now I can hear my audios in Ardour5
[15:19] <+abrock> if you don’t want to stop pulseaudio etc. every time you start Ardour you might want to install jack and configure pulseaudio to bridge to jack

Hello I’m facing a similar problem. When I import an audio file I can’t hear it, not in the preview nor in the project.

I have installed Ardour 5.12 in a linux 64bit Kernel 4.12.14 KDE plasma 5.12 with a Nvidia quadro M1000M. I have installed the Nvidia driver.

In the Audio/MIDi setup of the session I have to choose as output device the HDA Nvidia because when I try to select the HDA Intel PCH Ardour fails to open the audio device. So the only option to create a project is having as output the HDA Nvidia.

This the output of my sound cards:
cat /proc/asound/cards

0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xe444c000 irq 331
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xe4000000 irq 17

just click on the link in the bottom left corner of every page. It’s IRC access via your web browser. Not quite as nice as a real IRC client app, but far from bad.

Current default settings are as follows:

cat /proc/asound/cards
0 [VirMIDI ]: VirMIDI - VirMIDI
Virtual MIDI Card 1
1 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfcffc000 irq 27

From Audio/MIDI Setup Window

Input Device: HDA Intel
Output Device: HDA Intel

MIDI System: ALSA sequencer

Running AlsaMixer V1.1.1

Card HDA Intel
Chipset SigmaTel STAC9200
F4 [Capture]
L R Capture
Mic -----
Mic Boost 0<>0 (Bar graph is empty)
Capture 47<>47 (Bar graph is green)
Digital 24<>24 (Bar graph is green)

Where exactly would I find
hw:default or plughw:default

I really suggest you join us on IRC. Trying to solve this on a web forum is inefficient and frustrating.

My apologies. Where I currently work does not allow using IRC inside company firewalls, otherwise I would do so.

Probably never ever use hw:default with Ardour. This can be “redirected” to something like PulseAudio, which you never want. Always use “hw:NAME” where name is the name of the card (visible in the output of cat /proc/asound/cards in square brackets).

There are some intel HDA chipsets that for some reason get started up by Linux without the capture source being set to anything sensible. The result is that the capture side never becomes ready, and Ardour (or JACK or anything else that does duplex I/O (vs. just playback or just recording) will timeout waiting for it. So check after you’ve verified that you’re using hw:NAME, also use alsamixer from a terminal or an equivalent GUI app (gamix or qamix or others) to ensure that the capture source setting for the HDA is set to the right thing (typically some input jack or the mic).

What bufersize, samplerate are you using? What soundcard is that? If there is a continuous stream of x-runs (dropouts) Ardour’s ALSA backend will shut down after 2 seconds.

First, Thanks for such a quick response.
It is the Intel HDA motherboard sound chip, no other device used. There are no plugins, no outboard gear is used.
Buffer size is 2048. I can check on Monday but I think it is hw:default.

I do not experience any drop outs when it is working. Ardour actually works flawlessly :wink:
It is the cold boot issue that for some reason causes ALSA to be unable to connect with Ardour.

What is the audio device? What settings are you using?

BTW, Audacity does not use PulseAudio. It might open the ALSA device hw:default or plughw:default which on systems with PulseAudio installed will typically be the Pulse server.

The release version of Ardour is optimized, and the debug trace output is disabled.

In terms of solving problems like this quickly, IRC is often better.

I am running Red Hat Enterprise Linux Ver 7.4.
On cold boot, I launch Ardour 5.12.
I select any existing or new project.
When the window to start Audio engine is presented, I click Start and see ‘Running’ in Green for about 2 seconds. Then I get the ‘dreaded’ pop-up window that says ALSA I/O Error.
This occurs whether i am ‘root’ user or a ‘userland’ user.

I launch Ardour 5.12 from command line and watch the logs. I do see a ??? caught - shutting down (Forgot what ??? was). I see no errors in ‘dmsg’. I confirmed that no daemon for Jack or Pulse is running.

While reviewing some of the source, I see numerous potential error logging but I do not see any of it from terminal. Is there a command line flag to launch Ardour that will enable a more verbose logging? (Still working on building it…)

e.g. the terminal prompt I use to launch Ardour is similar to this:

user# /opt/Ardour5.12/bin/ardour5

The interesting fact is, I can run Ardour and it works just fine. There appears to be some issue after cold start. I do not have any other ‘unique’ process running.
That is, the same box running only Ardour will work just fine then for some reason after cold boot, it will not properly connect to ALSA.

I can launch Audacity and it will connect and run without issue. (I know Audacity uses pulse) . I have tried killing the pulse daemon after running audacity and i do not run Ardour and Audacity at the same time.


Thank you.