Line input


(Ag1455) #1

I had a strange problem after installation Ardour from SVN (Ubuntu 14.04): line input not connecting to Ardour. Only a microphone and I heard loud noise immediately after the addition of audio tracks (setup ALSA: alsa mixer: https://cloud.mail.ru/public/6f02bd10da6f/alsa.png).
I opened JackCtl and clicked “disconnect all”. Then I restart my computer and saw PulseAudio JACK Source:
https://cloud.mail.ru/public/020d68391499/pulse1.png
https://cloud.mail.ru/public/163943fd2ba9/pulse2.png
Then I run Ardour and now line input is connected and noise disappeared.
The next start computer was successful, but PulseAudio JACK Source did not appear.
https://cloud.mail.ru/public/acadf53b60f5/ardour1in.png
https://cloud.mail.ru/public/759b63b112f8/ardour2in.png
Is this normal?


(James Brierley) #2

PulseAudio JACK Source/Sink indicate the bridge which allows PulseAudio, which is the ‘consumer’ audio routing service used on Linux-based systems, to connect to JACK. This is provided by the module-jack-source and module-jack-sink PulseAudio modules.

You don’t need PulseAudio to route through JACK, so your second computer is perfectly normal and fine as long as you can hear what you’re doing when you want to! It’s just convenient in some instances. For instance, my FireWire audio interface is by definition not supported by ALSA but I am able to bridge applications through PulseAudio to jack-ffado using the above modules.

Cheers,
James


(Paul Davis) #3

(note: the next release of the Linux kernel will have ALSA support for firewire audio devices)


(Aklinbail) #4

Paul, do you have any more info on that?
I haven’t seen much info on the ffado-user list. Do you know if the existing devices will all be ported across to ALSA?


(Paul Davis) #5

I am not following developments closely. The alsa-devel list is where discussion would be occuring.


(AquaRious) #6

Hello,

I have same problem ,when i want to add a audio track it gets added with loud sound which lingers around till i dose not put input routing to disconnect. this happens on each track added in the same session.can you help me with this .

Thank you


(Robin Gareus) #7

That seems like a different issue than the one discussed here 4 years ago. It sounds like you get feedback:

microphone -> ardour-track -> speaker -> [air] -> microphone (repeat)

If you have a studio where this can happen, since Mic and Speakers are in the same room, prefer to disable ardour’s monitoring.

You can do that explicitly per track (In, Disk buttons in the mixer) or globally:

Either enable “tape machine mode” in (Preferences > Signal Flow) or disable “auto-input” (Session > Properties > Monitoring) or use hardware monitoring (also Preferences > Signal Flow).

It depends on your studio and workflow what is the best option… e.g. Do you want to hear/monitor yourself when recording or never…?