libsndfile 1.0.18

Want to compile 3.0 for testing and teaser but I have libsndfile 1.0.17 and 3.0 asks for 1.0.18, will making a simlink work?

Will this be the default lib required for the future 3.X releases of ardour?


This is the output I get when trying to build:

joe@ghubuntu:~/Desktop/3.0$ scons
scons: Reading SConscript files …
Checking for pkg-config version >= 0.8.0… yes
Checking for aubio… yes
Checking for ogg… yes
Checking for gthread-2.0… yes
Checking for lrdf… yes
Checking for libgnomecanvas-2.0… yes
Checking for gtk±2.0… yes
Checking for jack… yes
Checking for flac… yes
Checking for sndfile… no
sndfile >= 1.0.18 not found.
You do not have the necessary dependencies required to build ardour
Please consult for more information

As stated, you are REQUIRED to have 1.0.18, which is available as pre-release from the libsndfile website.

3.0 is a bleeding edge work, we don’t plan to make it easy to build or install until we get closer to a release. By which time we hope Erik will have officially released 1.0.18.

Ok thanks…

Also, setting SYSLIBS=no (to use the bundled libs) doesn’t help either.