libgnomecanvas-2.0 >= 2.0 not found.

Hello. (I’m spanish and my english is very poor)

When I try to install ardour typing “scons” it gives me “libgnomecanvas-2.0 >= 2.0 not found.” but I have 2.14.0-69 version of libgnomecanvas.

What can I do?

you probably do not have the -devel version of the package installed. this is explained on the build page, accessible from the full download page

I have a similar problem.
I am trying to compile ardour-2.8.9
on Fedora Core 9 and I have the following packages installed


but I still get
scons: Reading SConscript files …
Checking for pkg-config version >= 0.8.0… yes
Checking for gthread-2.0… yes
Checking for lrdf… yes
Checking for libgnomecanvas-2.0… no
libgnomecanvas-2.0 >= 2.0 not found.

Any ideas on how to handle this?
Thanks in advance,

I’ve been trying to build with scons 1.3, and I get:

AttributeError: LibraryInfo instance has no attribute ‘Object’:
File “…software/ardour-2.8.9/SConstruct”, line 882:
if conf.CheckHeader (‘fftw3.h’):
File “/usr/local/lib/scons-1.3.0.d20100606/SCons/”, line 648:
ret = apply(self.test, (context,) + args, kw)
File “/usr/local/lib/scons-1.3.0.d20100606/SCons/”, line 946:
include_quotes = include_quotes)
File “/usr/local/lib/scons-1.3.0.d20100606/SCons/”, line 358:
ret = context.CompileProg(text, suffix)
File “/usr/local/lib/scons-1.3.0.d20100606/SCons/”, line 839:
return not self.TryBuild(self.env.Object, text, ext)
Checking for C header file fftw3.h…

Any clues? the fftw3.h file is in /usr/local/include, also in /usr/include

There doesn’t seem to be any -devel version of fftw. Where can I get the -devel version of fftw, or were you referring to another package?