Lexicon Omega USB, Alsa and Jack not working


Sorry if this is maybe not the right place to ask but if tried a lot of different places and nowhere I could be helped. I guess here there’s a lot of people knowing their business.

So the thing is I recently purchased a Lexicon Omega Studio USB Interface and it’s simply not running in duplex mode. The outpus of jackctl is

jackd 0.116.1 Copyright 2001-2005 Paul Davis and others. jackd comes with ABSOLUTELY NO WARRANTY This is free software, and you are welcome to redistribute it under certain conditions; see the file COPYING for details JACK compiled with System V SHM support. loading driver .. SSE2 detected apparent rate = 48000 creating alsa driver ... hw:1,1|hw:1,1|256|2|48000|0|0|nomon|swmeter|soft-mode|32bit control device hw:1 configuring for 48000Hz, period = 256 frames (5.3 ms), buffer = 2 periods ALSA: final selected sample format for capture: 24bit little-endian ALSA: use 2 periods for capture ALSA: final selected sample format for playback: 24bit little-endian ALSA: use 2 periods for playback ALSA: could not start playback (Broken pipe) DRIVER NT: could not start driver cannot start driver

I don’t really know what a ‘broken pipe’ is and I couldn’t find an answer on the internet so maybe someone here can help me. In fact in either Capture only Playback only mode it’s working perfectly fine so…
I don’t know, I’m sad - too many hours spent on this already with no outcome. Maybe you can help me!
Thanks a lot!!

I would appreciate any comment on this!!
What is a broken pipe? Where could I start to look? Should I try older ALSA/JACK versions? Why could it be working capture/record only but not duplex?
Or some links, some information, please!!

@osterchrisi: your problem has nothign to do with a broken pipe. The most likely cause of your problem is that you are using a consumer/desktop/gamer audio interface which is not designed for proper duplex operation. What type of soundcard is it?

Paul ill save you some trouble there, its in his first post;)

To the OP: However that being said, that doesn’t mean that is the soundcard actually trying to be used by Jack obviously, can you paste the output of…

cat /proc/asound/cards

for me?


Hey thanks for that. I’ve gone through some helping already so I have some information packed nicely together for you:
Jack error message: http://pastebin.com/4d2M0mny
aplay -L && arecord -L: http://pastebin.com/PM1ZjKBj
cat /proc/asound/cards: http://pastebin.com/mnq6FhMf

So as far as I was already told, only “USB Audio” and “USB Audio #1” are in question to work. I tried every setting with the two - but as I said: Duplex doesn’t work. But I read on different pages that Linux Users got it to work perfectly on their systems (out of the box) and also on the ALSA page it is said so… So maybe it’s something minor I can’t know.

Shall I maybe try a newer version of JACK? I run 0.116.1-4ubuntu2 now but I’ve seen that there’s already 0.118. out. Or maybe I run on an old ALSA version - where can I look that up? If it’s alsa-base I run 1.0.20-dfsg-1ubuntu5. Ok yes and I run a Ubuntu Studio 64…

Thank you very muccccchhhh!!!

Hmm well for one thing you seem to have two different messaging there, which makes me suspect part of your problem is the familiar rotating of sound devices on boot. Were all of those pastebin messages from a single boot? If so can you for grins and giggles try something for me, just increase the periods/buffer size to 3 from 2, this helped with some USB devices in the past, though not with this specific problem, it can’t hurt to try it and reset it if it didn’t help.


No, they are not from a single boot. The number (hw:1 or hw:2) depends on if I have my USB mouse plugged in or not. I tried all settings concerning the periods per buffer from 2 up to 8. Didn’t help either…
Tell me if I can provide more information! Thanks again!

Ok, I figured out now! Thanks for the hint by the ‘single boot question’!
I’m unfortunately not allowed to plug my USB mouse into my laptop as long as Jack is not running… What a strange thing… But ok, at least now I figured out :slight_smile: And this also explains why I had it running in the very beginning for one time but afterwards it won’t start anymore.

Does someone then maybe have a clue how I could solve this problem? A USB mouse is quite comforting when working with Ardour…
But thanks anyway for all the supporrrrrtt!!!

Did you ever arrive at a cleaner solution? I’m in a similar situation.

Unfortunately no… (See your other thread)…

USB1.1 hubs can cause trouble.

I found this ticket after searching around a bit - I too was having the same symptoms with my PreSonus “Audiobox USB” device. It could capture or playback, but not do both at once. Ie. jackd would fail with;

ALSA: could not start playback (Broken pipe)

So I wanted to mention what I found that fixed the problem for me, in case it fixes the problem for you too. (Note also that “osterchrisi” mentioned another thread, but I didn’t see any link so I couldn’t go there to see whether this suggestion was already made.)

It turns out that the problem I had was USB 1.1!! In particular, I had one of these cheap USB hub/splitters (bus-powered), and it seems that it was forcing devices plugged into it to communicate with the PC using USB 1.1. Rather than failing altogether, this was just limiting the functionality. When I plugged the Audiobox directly into a distinct USB port (I had an unused eSATA port which is USB compatible), bingo - it was able to capture and playback at the same time!

Someone mentioned that plugging in a USB mouse was causing their problem - I wonder if they were using a USB hub to do that, like I was? Anyway, I mention all this in the hopes that it helps someone who comes across the same issue I faced. FWIW, I’ve ordered a better USB hub (with DC power, and specs that indicate full USB2 end-to-end support) in the hopes that this will do the trick.