Latest nightly PPC build is japanese? Changing language?

Hi, I’m new here,
Longtime Mixbus user, recent Ardour subscriber. I got hold of an old Quad core G5 last week and was psyched to learn that Ardour is still being built for these wonderful machines.

I downloaded the last nightly build and it loads, tracks and appears to function fast and nicely however it’s in Japanese and I can’t make heads or tails of changing the language. I’ve tried looking around the forum without much luck. It’s been years since I’ve used a MAC and I’ve never used Ardour before, and although it’s almost identical to Mixbus I’m unable to navigate to a “preferences” or “Options”.

There’s Preferences > Appearance > Translations > Use translations


If you cannot find, that in Japanese, close Ardour, open a terminal and run:

echo -n 0 > ~/Library/Preferences/Ardour6/.translate

This create a file Library/Preferences/Ardour6/.translate in your home folder with the number zero in it. Then restart Ardour and it should be in American English.

As for the root issue. Could it be that the OS’s default was Japanese and English was only added as 2nd language?

Thank you, I will give this a try right away. Osx defaulting to japanese would be crazy, as I am Norwegian, with a norwegian keyboard. I installed OSX in norwegian and has Oslo, Norway in “time zones”. Could it be that Ardour wanted to go for Norwegian and couldn’t, so it went for the closest language, Japanese? :stuck_out_tongue:

I tried it but It’s still in japanese. Well, actually it appears to be a mix between japanese, french and some english. :confused: I figured out that the shortcut to prefs should be “alt+O” but that does nothing, and the drop down menu shortcut that has “alt+O” as it’s keyboard shortcut also does nothing… :frowning:

Could you make a screenshot (command + shift + 3), that would at least be entertaining :slight_smile:

Some English terms are expected (since japanese translation is incomplete), but French is odd.

BTW Option + O shows the session properties, not preferences. IIRC Apple’s default for preferences in (commmand + ,). Since you mentioned “Alt”, do you use a PC-keyboard? It’s likely easier to use Menu > Window > Preferences > Show

Have you tried it using the terminal? It’s in /Applications/Utilities (or search for it via spotlight). and call echo -n 0 > ~/Library/Preferences/Ardour6/.translate ?

Yes, I did try the terminal command. I fid manage to get it working now however.
I installed Ardour on my windows laptop and compared menues. I noticed there was a PREFERENCES in the WINDOW dropdown menu as well. Once I got that set to SHOW preferences appeared. After i turned off translations and restarted it was all in english :slight_smile:
It crashes when I try to record however :smiley: While recording it works fine but after hitting space (for “done recording”) it crashes. I’d like to help in any small way that I can so I’m looking for the correct way to post a crash report now.
I have to say it’s really usable in terms of performance. With buffers set to 256 i was able to almost-record a stereo guitar track out of my eleven rack without DSP goinf higher then 60%

I see “Bug Tracker” only lists osx 10.6 or newer. I guess I’m a fringe case :smiley: Does anyone know how I should go about reporting this crash to whoever is working on the PPC OSX code?

I did a quick test running the PPC build it on 10.6 (intel, with Rosetta PPC emulator) and that works. Can record and stop.

I don’t have Apple/PPC hardware to test anymore.

Does the crash also happen when you disable rec-arm or the track or globally while rolling (and only stop later)?

Does Apple’s CrashReporter window come up? If so yes, please copy/paste a backtrace and file report it on the bug-tracker. Can you also try if a debug-build crashes in the same way?

There is nobody working actively in the PPC build (and we’ll likely discontinue it soon), but It’s me who does those builds and I can perhaps look into some maintenance if it is an easy fix.

Cool, disarming the track while rolling worked and the take gets recorded. I then tried keeping the tracks record-enabled and just hitting stop in the transport (not space on the keyboard): that also worked. I THEN tried recoring and hitting space and suddenly it didn’t crash… I did post a bug report before trying this and pasted in the crash reports from OSX (two of them). But perhaps my crashes were just flukes? I don’t remember if I’ve restarted the machine since then…
I’m sorry to read that you’ll be discontinuing the PPC port, allthough I do ofcourse perfectly understand! It is unreasonably cool to keep putting them out :smiley:
I’ll be be beginning my computer engineering degree this fall. It’ll probably be a long time until I’m useful in any real way, but I’ll be happy to help out in any way that I can in the coming years.

Could also be some random case (uninitialized memory, or some memory-corruption), the second backtrace (which is sadly cut short) hints at that.

Thread 19 Crashed:\
0 libSystem.B.dylib 0xffff8c00 __memcpy + 1120 (cpu_capabilities.h:237)\
1 libardour.dylib 0x017c4b94 std::vector<ARDOUR::CaptureInfo*, std::allocator<ARDOUR::Capt

There may be some related crashes down the road. Anyway, I’m glad that it works now.

The real reason behind this is that starting Ardour 7, we’d like to use some modern C++11 features (also 10 years old by now). Only macOS 10.9 or later has support for this. It is theoretically possible to backport a compiler and standard libraries, but the effort to do so is no relation to the benefit. Our limited time is spend better focusing on Apple/ARM M1 CPUs.

Then again, all the source-code is available, so if someone wants to dive into it…

I’ve had a few ‘crashes’ with Ardour 6.6 under Win 10 when using the space bar to stop transport. Sometimes it recovers the data when restarted other times it doesn’t. Never saw the issue with V6.5. Have dusted off an old laptop and using 6.6 under Ubuntu Studio 20.04 without similar issues.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.