Latency on 64bit system significantly higher then on 32bit system

Hi, All,

I’e had netbook with Atom N270 CPU (very poor performance, of course], so the system was well tuned. Nowadays i bought new machine - quad core i5 3GHz, 4G RAM. I copied my old filesystem to this new machine and tried some audio processing. I was surprised - i ran Mixxx (dj app) for 8 hours at 1.45ms (lowest possiblevalue in Mixxx) latency without any xrun. Excellent! Jack+ardour - similar results (2 buffers 64 bytes at 44k1). Perfect!

I decided to switch to 64bit system. I installed the system on new partition (logical volume), i compiled Mixxx, Jack, Ardour + necessary basic libraries. I copied /etc and /usr/local/etc from old system to the new one, so i have two very simillar systems - 32b and 64b on the same machine.


latency on the 64b system is much higher - i need 256 byte buffers in jack or 5ms latency in Mixxx to not get xruns.

It makes me crazy - i really dont understand why latency is 4 times higher on my 64bit system?


  • Slackware 14.1 (32b and 64b)
  • newest jack-2
  • latest stable ardour
    HW M-Audio Fasttrack ultra 8R (8x8 USB 2.0 interface)
  • kernel 3.10.67-rt69, built myself, exactly the same configuration (except arch, x86 / x86_64)

Has anyone any idea why is it?


I apologize for this question - i found my stupid mistake :-). I use set_rlimits utility to give RT priority to jack and apps. I didn’t set suid bit on set_rlimits, so all audio apps didn’t have RT priority.

Now, everythink works fine.

Sorry again.