Latency compensation in layered loop recording

Hi all,

I am using Ardour 5.12.0 32 bit on windows 7, in conjunction with a Steinberg ur22 and a pod xt. I use ASIO drivers for both.

I encountered a problem with latency compensation with both these interfaces. I measure the roundtrip latency for a given audio buffer size and I set it in the “hardware input latency” field in the Audio/MIDI setup panel before Ardour starts.

When I do a layered loop recording, the first run is correctly compensated, while all layers from second on are not compensated (they have latency).

Am I doing something wrong? Is there a fix for this?

Thank you all in advance.

We’re probably not likely to comment much on this in the near future, because latency compensation is being totally overhauled as part of the development of version 6.0 (whose release is a long way off, and very definitely not imminent in any way). It sounds like a bug, for sure.

Allright, good to know anyway thank you. I’ll post something if I find a workaround. In the mean time, it would be interesting to see if anyone experienced a similar problem and how they solved it.

Sorry for reposting, is there a way to drag and drop all layers of a loop recording at once? Because then I could set the latency to zero in the settings (no latency compensation) and just realign the bundle of layers when I’m done with a part

One possible “manual” workaround is to count the number of samples regions needs to be moved after recording and setting this value in the Editor window “Nudge Clock” box. It is a small time display right above the tracks. First right click on it and set it to display samples, then write in the amount. Then select a region and click on the back arrow (Nudge region earlier) on the left side of the “Nudge Clock” display. Done.

If you don’t have too many takes at the same spot in time, then you can make the track bigger and set it to display all the takes simultaneously (right click on the track header and select: Layers / Stacked). This makes it easy to align the takes after recording and if you miss one you can always check that the starting edge of the region is at the same spot in time as the others.

To add on to what mhartzel mentioned, you could drop a marker at the region start of the correctly aligned region, set your grid to snap to marker, and then drag the other regions to snap to that marker you added and it would align all of them. I haven’t tried this in stacked mode, but used to do this often to align regions across multiple tracks.


There’s an “Align Region” operation that may be useful too.