Language change as a preference

Hello fellow ardourers,

the choice of Ardour’s language is, as I understand from other posts on this forum, currently based on the locale.

It would be very helpful if we could change the language from the preferences menu. A few use cases where it would be beneficial are :

  • incomplete or poor translation (rather use it in english, then)
  • following a tutorial in another language (mainly english, again)
  • working on translation & keyboard shortcuts (which is my very narrow case)
  • explaining a problem / showing a screenshot on this forum for non-english speakers
    etc…

One unobtrusive way to do this would be to have a combo box in the preferences :
Language : [ Auto (locale) | / ]

  • Deutch
  • Espanol
  • Francais
  • … (all the supported languages, in alphabetical order)

Auto would be set by default to behave exactly as usual for uninterested users.
This preference could be added to Ardour’s ‘config’ file in a .
To be backwards compatible, no , or <option name=“language”=""> or <option name=“language”=“Auto”> would default to the locale.

Maybe I’m missing a reason why the choice of language is not shown to the user, but if not, it could be very helpful, and handier than changing the locale before running Ardour.

Thank you !

(Edit)
(Sorry, all the tags have been removed : )

This preference could be added to Ardour’s ‘config’ file in a tag : option name=“language” value=“Deutsch”
To be backwards compatible, no language option, or option language="" or option language=“Auto” would default to the locale.

Absolutely no plans to do this.

You can enable/disable translation entirely from Edit > Preferences > User interaction.

You can choose the language for Ardour just as you can with any other application, by setting an environment variable in a shell or in your desktop environment. Typically LC_LANG is the one, but that can vary from platform to platform. We are not going to add a mechanism internally when your OS already has tools to set it more generally.

1 Like

Ok, thanks, Paul, I was just missing the Edit > Preferences > User interaction !!!

I’d also appreciate help changing the language: I have a Mac purchased in Austria but my primary language is set to English. Yet, when I downloaded Ardour 4.7 today and installed it, I get everything in German. How do I switch to English? Thanks

Hey guys, I just downloaded Ardour and I encountered the same issue since it was set to the language in which the OS was installed. After I deactivated translation by user interaction (that name might be wrong) it went back to English and now it’s fine!

Hello Guys, i just downloaded Ardour on my Mac and it wouldn’t let me install says my security preferences,i have cheked it but still wouldn’t let me install. I am on OSX EL Capitan

You're hijacking a thread that has absolutely nothing to do with installing Ardour, El Capitan or OS X security preferences.

This is a common problem for 3rd party applications that have chosen not to get "signed" as part of Apple's development system. Apple document it all here:

https://support.apple.com/kb/PH21769?locale=en_US