Laggy \ Broken Recordings


Have spent many a day now going around in circles…

Basically, I have a Roland RD700-SX Digital Piano, Edirol UA-25 and are using JACK via Qtjackl on Fedora 8. JACK appears to be connecting fine 'server started ’ etc. Oddly, I did have to turn Real-Time off, did this as I read somewhere it wouldn’t work with Fedora 8? Not sure about this though once I did - it worked. (Also read you can d/l and install real-time???)

I can currently record onto tracks and play them back - can hear everything etc … what an adventure getting that to work was!

However, the problem I currently have is that the recordings are very laggy and they seem to stop\start etc. End result is a really choppy sounding file missing rather large chunks of audio.
The parts that are recorded\played back correctly sound of good quality. I dont think it’s computer related, it’s running on P4 3.0Ghz with 2gb ram and plenty of HDD space - the only thing I haven’t tried is perhaps recording on to secondary HDD? I’m working on primary.

Unfortunately I’m new to the Linux world and my trouble-shooting skills aren’t the best yet, I will really appreciate any advice\assistance provided!


Your problem sounds related to the way in which jackd is running.

Firstly, try setting the number of periods jack uses to 3 for USB devices. Hopefully this will reduce the number of xruns you experience.

Secondly, get realtime working. Realtime works fine on f8, but in order to use it you must alter the file /etc/security/limits.conf and add the following before logging out:

# limit realtime and memory locking access to users in the group audio # there is no way to say "allow locking all memory", 4G should be enough # #* - rtprio 0 #* - nice 0 # #@audio - rtprio 99 #@audio - nice -10 #@audio - memlock 4000000

or (default) allow everyone access

    • rtprio 99
    • nice -10
    • memlock 4000000

When you log back in, you should be able to use realtime in jack.

if this seems too hard, try installing planet CCRMA, whose jack-audio-connection-kit rpm alters this file for you.

Still no luck figuring it out.

It’s as if the XRUN runs then stops for a short period, then starts running again.

If I hit record on a track, regardless of anything actually being recorded, the clock pauses on these times: 1.15, 2.29, 4.14 … and on and on … pause time can range from 3 to 10 seconds.

System info appears fine, CPU rides around 20-30% mostly and only 400MB (of 2GB) appears to be in use. No wild process or services running. I even made a new account and only placed it in wheel + audio group … same issue.

One thing I did notice though wasn’t sure what the figures related to where at the top right of ardour, this is what it says;

44.1Khz, 23.2ms Buffers p 81% c: 72% DSP: 5.0% - I fiddled with the latency to see if that had any effect, it did though not by much at all.

Whoops - hey thanks nick, I’ll give that a whirl and post back shortly!

You’re a legend! Changed Period to 3 - works beautifully, haven’t experienced any pauses at all and it sounds great!

I then went on to tackle the realtime issue;

Entered the following into /etc/security/limits.conf using Vim;

    • rtprio 99
    • nice -10
    • memlock 4000000

Qjackctl starts though stops shortly after, message log has the following info if it’s any use?

21:46:48.109 Patchbay deactivated.
21:46:48.170 Statistics reset.
JACK tmpdir identified as [/dev/shm]
21:46:48.232 ALSA connection graph change.
21:46:48.380 ALSA connection change.
21:46:58.055 Startup script…
21:46:58.056 artsshell -q terminate
JACK tmpdir identified as [/dev/shm]
21:46:58.490 Startup script terminated with exit status=256.
21:46:58.491 JACK is starting…
21:46:58.492 /usr/bin/jackd -R -P1 -dalsa -dhw:0 -r44100 -p1024 -n3
21:46:58.496 JACK was started with PID=3889.
jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver …
apparent rate = 44100
creating alsa driver … hw:0|hw:0|1024|3|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 1024 frames, buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 3 periods for playback
21:47:00.507 Server configuration saved to “/home/audio/.jackdrc”.
21:47:00.508 Statistics reset.
21:47:00.535 Client activated.
21:47:00.536 JACK connection change.
21:47:00.557 JACK connection graph change.
JACK tmpdir identified as [/dev/shm]
cannot use real-time scheduling (FIFO at priority 0) [for thread -1225544816, from thread -1225544816] (22: Invalid argument)

Thanks again!

Did you log out and back in again before you tried to start jack?
This means logout completely, not just your terminal program.

Yeah, logged out and back in. I even tried restarting though had the same problem.

Being that I’ve run around in circles and now understand the few changes I need to make, I’m strongly considering doing a full re-install of Fedora 8 … Theres a strong chance I’ve changed other stuff without realising and installed other stuff that isn’t needed. May have something to do with this issue and others further down the track.

Doesn’t bother me and I feel it’s a good way of familiarising with linux.

What do you think, a good idea or a little drastic?

I’d suggest you join the #ardour channel on freenode to discuss this further.

No worries, thanks for your help!