Kwin window rules (Fullscreen)

Hello!
Guys… is there any workaround to keep a plugin window on top even with that “force” window rule setting? I mean… it works when you have Ardour window maximized but when you’re in full screen mode if you click outside utility/dialog window the Ardour GUI comes up and hide my plugin window. Under GNOME desktop the window behaviour works flawless! I wonder if I could achieve same functionality here on Plasma… Sometimes I just want to click outside my focused window to press some keyboard shortcut without losing focus from that window at the top. I can’t even run Ardour without fullscreen mode because it won’t fit to my screen resolution properly (1366 x 768). I wouldn’t mind if I could run Ardour maximized, but… I even tried Gnome recently to see if would be okay to remain there working and unfortunately I couldn’t stand for all the bugs I found that would hinder my work so I went back to the plasma again but this little thing here annoys me.

Which of the following have you tried?

e

Paul,

I always keep “All floating windows are dialogs” option enabled so I can use alt+tab to bring back that window overlaid by full screen mode. Nothing else.

And as I said before, I keep following these workarounds since I discovered it:
https://manual.ardour.org/ardour-configuration/system-specific-setup/kde-plasma-5/

Thanks.

PS: I keep Ardour’s default “Use visibility information provided by…” unchanged.

EDIT: I gave another shot to those options yesterday but no effect on my situation.

I have got KDE Plasma installed on my 1366x768 Dell laptop. When I run Ardour maximized (with KDE panel on the top of the screen - with “Active Window Control” widget - which keeps the panel and window bar integrated) it scales beautifully - as of version 6.0.0. To keep the editor window bottom layer I do: Alt+F3 > More Actions > Special Application Settings >Arrangement & Access >Keep Below > Force > Yes , click OK at the bottom right of the dialog and it works for me.
I run Debian 10, Stable with Plasma 5.14.5.
It looks like this:

I use Active Window Control here too but without this integration between panel and window bar. Perhaps would that also be a temporary solution for me even when I don’t really want all my windows to integrate with the panel. I tried many settings here in Kwin window rules and I feel as if dialog/utility window aren’t able to merge with fullscreen. The mutter on Gnome doesn’t seem to disassociate dialog and utility from main window like Kwin does.

This is how Ardour looks maximized here:

I had the same problem, bottom being cut off when maximized, with Ardour 6-pre release. I also remember that problem existed in plasma/kwin and one more WM (I can’t remember which one exactly), but it was completely fine with others. I even filed a bug report… However, with Ardour 6.0.0, official release, the problem was gone. Did you get the Ardour from ardour.org or from your distribution’s package manager? The official build seems to work just fine for me.

Always from ardour.org. I’m running at this moment a nightly build (6.2.138) because it comes with a important graphical midi bug fix that I came across. In the past I even installed Ardour from distro repos for a while and the reason for that was to work around a issue with fontconfig in non-lts releases that I was using before. But just to clarify something about this subject: the problem with window/resolution is also present on Gnome 3 since ever on my machine. On Gnome, for example, there is just minimize and close buttons. I remember by chance that I didn’t have this problem with Gnome 2 on Ubuntu Mate but with Plasma and Gnome 3… always. Well, luckily the plasma allows me to easily workaround this situation on my laptop but to be honest, I would love if I could run Ardour in full screen without any problems (as it happens on gnome) using KDE plasma.

Perhaps Ubuntu Studio can change this scenario from now on if it starts working together with Kde team/community in the future. I don’t think it’s something that belongs to the Ardour developers once it was born in the plasma yard. People who develops Ardour are just kind when they try to help find a solution for these situations like mine and I know they try to code a software able to suit all kind of distros.

Please, if there is something I can try… Count on me! I’m listening. Any trial can lead us to a solution someday if this topic helps somehow.

If I remember correctly, Ardour 6-pre did fit the screen fine when maximized with a vertical panel, like in this picture:

One other possibility is to set the panel in auto-hide mode. That way you can have Ardour both fullscreen and bottom layered.

There must be a way to add maximize button in Gnome Tweaks or System Settings. The problem I personally have with Gnome 3 is that it keeps indexing new files in the background (supposedly for easier searching afterwards), thus using precious resources on my low spec laptop. That is something I don’t want during live recording. KDE will do that too, if there is Nautilus installed, but at least you have the choice. Besides, Dolphin is fantastic file manager if you ask me. When I’m doing some critical work I don’t log in DE at all. I’m using only Fluxbox WM.

It is very annoying, albeit useful. I find the default settings quite aggressive though.

Before starting Ardour you can type in a terminal tracker daemon -t, to terminate all the indexing processes. They will then start again at the next reboot (or you can type tracker daemon -s when you are done). I usually let the indexing run during the night.

1 Like

No, I am aware of that … I meant this is something that happens only with the Ardor window.

I tried it here right now and it works but I need remove the window border through alt+f3. This is a vertical space problem for Ardour I guess. Ardour doesn’t fit this resolution vertically correctly and I don’t know why yet.

Here is something I realized:

Yes, I did this intuitively before but I really don’t love this autohide thing.

And for sure! Nautilus is fantastic. I installed it on gnome because I find nautilus quite limited. Kde does that indexing file thing with baloo, doesn’t it?

1 Like