Korg NanoKontrol

Hi everyone,

Does anyone know if Ardour works with the Korg NanoKontrol?
I found already this topic (http://ardour.org/node/650) , but it didn’t help me.

I’m using Midi-Patchbay, where I connected the NK to ardour and I enabled ‘generic midi’ in the options menu.
I also checked the Midi Options in the Preferences Menu, but it doesn’t work.

Kind regards,

I see no reason why it wouldn’t. You didn’t say you did this so I have to check, you did CTRL+MiddleClick to bind the MIDI signal sent by NanoKontrol to whatever control you wanted it to control correct?


thanks a lot, that was the problem…
I’m using a Macbook Pro and until now I was just controling with the trackpad, which can’t simulate the Middle Click.


Yep read the first time OS X user page;) Sadly a good mouse is required pretty much since apple seems to love their design over function approach in some regards, including basic things like a mouse.


Getting a Korg NanoKontrol working with Ardour on Linux doesn’t all seem to be documented in one place, so here’s what I did:

  • My NanoKontrol shipped with the buttons set in "momentary" mode. This meant that when I mapped them to solo/mute/record, or whatever, they wouldn't stay on unless I held them. I had to download KontrolEditor from the Korg site and use it to set the buttons into momentary mode. Apparently Kontrol Editor runs in WINE but I used a Windows Vista VM. Note that KontrolEditor lets you select the first button and shift-select the last from the list on the left and then change all of the modes at once. I did this for all 4 scenes. I didn't read the documentation but I did things from the "Communicate" menu (or similar) that seemed to actually write the configuration to the NanoKontrol - it asked for confirmation. Some things I did might be overkill but I decided to be as complete as possible because I only wanted to do this once.
  • In qjackctl, in the Connect/Connections widget, on the ALSA tab I connected the output from the NanoKontrol to Ardour's 0:control MIDI port. I can't see how to save this, so I think I need to do it each time I start jackd and Ardour. Anyone?
  • In Ardour, I made sure Options -> Control Surfaces -> Generic MIDI was checked. I also went to Window -> Preferences -> MIDI (tab) and ensured that the control port had MTC, MMC and MIDI Parameter Control assigned to it.
  • I was then able to control-middle-click on widgets in the Ardour interface and press/move things on the NanoKontrol to assign them. Similarly to others, I wasn't able to get rewind and fast-forward to do anything when mapped. So, in KontrolEditor, I changed those buttons into MMC mode. They now do a rewind and fast-forward scan operation (rather than the convenient jump)... but at least they do something... ;-)

From there it will be a process of creating a decent template… something I should do anyway to improve my productivity…

I did the above but also had to make sure that Options -> Control Surfaces -> Remote ID assigned by User was selected.

Otherwise Ardour wouldn’t take the settings when trying to use Right-Shift + Middle Button learning.

I disconnected and reconnected the nanoKONTROL to Ardour’s MIDI control in, and it all worked for a while. Then Ardour crashed… and when I reconnected it again, strips 1-8 wouldn’t function again.

There must be something about when it gets connected and how the bank size or current bank gets initialised…

I’ll try to figure out something more systematic when I’m more awake… :slight_smile:

Now trying to get the nanoKONTROL working in A3…

I’ve selected “Korg nanoKONTROL w/Master” in the Control Surfaces/General MIDI preference. I’ve got the nanoKONTROL connected to the “MIDI control in” port.

I read through midi_maps/Korg_nanoKONTROL_Master.map and I think I’ve setup the nanoKONTROL to match. In KontrolEditor, I loaded the factory reset configuration file and then :

  • Changed all the buttons in scene 1 from "momentary" to "toggle".
  • Saved scene 1 into a file, loaded it to each scene, renamed the scenes and sent them to the nanoKONTROL.

As a result, the transport works and and strip 9 works for the master fader and other functions.

However, strips 1-8 don’t do anything. The MIDI trace window shows me this for strip 1 (in decimal mode):

14:59:18.587568      Controller chn  1 23 0  
14:59:19.197566      Controller chn  1 23 127
14:59:20.845632      Controller chn  1 33 0  
14:59:23.182097      Controller chn  1 33 127
14:59:26.337048      Controller chn  1  2 66 
14:59:26.363120      Controller chn  1  2 67 
14:59:28.827791      Controller chn  1 14 61 
14:59:29.207794      Controller chn  1 14 62 

These seem to match the definition for strip 1:

<!-- Strip 1 -->
  <Binding channel="1" ctl="14" uri="/route/pandirection B1"/>
  <Binding channel="1" ctl="23" uri="/route/solo B1"/>
  <Binding channel="1" ctl="33" uri="/route/recenable B1"/>
  <Binding channel="1" ctl="2" uri="/route/gain B1"/>

I’m sure I had strips 1-8 working last week… but I can’t figure out what has changed.

It is almost like there is no bank selected, so the events aren’t being routed to the right controls. However, I’ve got no idea how to debug this… :frowning:

Any ideas?


how to set the next and prev track selection keys and bank change keys?

@Scott Lavender

In order to use the midi maps you’ve got to set the Chanel to “follow the Editor order” after choosing the surface.
In my setting , under linux, in Jackcl, I connect in ALSA “nanoKontrol2” to “midi through”, and in midi “a2j” to “Ardour Midi control in”
I’ve added “/usr/bin/a2jmidid &” to the starting script in jackcl to start a2j autocratically.
In my work flow, I’ve made an Ardour template with those setting, and now , every time I start a new mix, I create it loading this template.
After saving and closing, now, in Ardour 3,4, it’s persistent between session.