Kontakt and multiple midi tracks

Hey, Ardour noob here.

First of all, sorry for my english, I’ll probably make some embarrassing spelling and phrasing mistakes.

I’ve been using Ardour for a couple of days and I’m trying to understand the subtleties of the interface. I usually use ProTools/Cubase/Logic and this DAW, as wonderful as it is, can be very intimidating and confusing for a beginner, like myself.

I’m facing a problem that drives me crazy: I’m trying to route audio from each Instrument loaded in KONTAKT’s rack to separate midi channels.

Here’s what I did: I created a new bus track and opened Kontakt as a Vst plugin (like I usualy do in Logic) and I created several midi tracks and routed each track to my Kontakt track, but I didn’t manage to isolate each instruments, they play all together in unisson. I tried to change midi channels, but it doesn’t make any difference.

What I am doing wrong ? What is the procedure ?

Guise, please help me, before I go crazy, start crying and call my mom. She won’t help me anyway; she doesn’t know anything about Adour :slight_smile:


Windows 10 - Komplete Audio 6 - M-Audio Oxygen 25

When you say “tried to change midi channels”, do you mean editing the midi channel for individual notes, or using the track midi channel selector? Do you get different results during recording and playback, or the same?

Hi. With the channel selector :slight_smile: I opened a bus track with a Kontakt plugin and loaded several instruments (Spitfire Albion ) and now, I’m (still) trying to distribute each instrument (brass, strings, woodwind) on their own midi track (by right-clicking on the tracks and using the channel selector).To be honest, I don’t even know if it is the right thing to do. I can only hear the first instrument on the list. The other midi track don’t have any sound. Same results when recording and playback.

The other option would be to load Kontakt on every midi tracks (tried this, it works) but, in the end, it would be quite heavy for my computer.

Otherwise, great DAW.

Do you get different results during playback vs. recording? The reason I ask is because I had a similar problem while trying to use LinuxSampler:


Paul’s response was:

The MIDI channel selector only operates on material read from disk (or written to disk), not from live input fed to the output stream. There are some plans to change this, but they are not implemented at this time.

x42 (Robin Gareus) has some MIDI channel mapping plugins that will do what you want.

I got the same results during recording and playback :frowning: but now I think I (maybe) found a solution.

Here’s what I did, following the instructions of this french mime demonstrating how to use LinuxSampler https://www.youtube.com/watch?v=JquEnbV5nTw

  • opened 16 midi tracks without instruments
  • created a bus track with my Kontakt (or any other plugin)
  • opened three instruments in Kontakt
  • routed the outputs of my midi tracks on the input of my Kontakt bus
  • routed my keyboard on the input of my midi tracks
  • opened the x42 midi channel map plugin on each midi track (on top of the fader)
  • chose the right channel for each instruments (Channel 1 to 1, Channel 1 to 2 …) Now each instruments is on his own track.
    Now the tricky part:
    All the instruments are playing all together, I had to solo a track to ear a single instrument, or disable the midi input button. Now I can record each track individually (IN to record and DISK to playback)
    There. I kinda feel like I discovered a thing well known in the Ardour community (like, a basic feature) but it’s great to be able to record my music.