Keep getting errors

Hi, I keep getting errors in Ardour. Like these:

[INFO]: Loading session /media/DATI/evve using snapshot evve (1)
Loading history from ‘/media/DATI/evve/evve.history’.
[ERROR]: MMC: cannot send command 8
[ERROR]: MMC: cannot send command 6
[ERROR]: MMC: cannot send command 3
[ERROR]: MMC: cannot send command 7
[ERROR]: MMC: cannot send command 1
[ERROR]: MMC: cannot send command 44
[ERROR]: MMC: cannot send command 3
[ERROR]: MMC: cannot send command 1
[ERROR]: MMC: cannot send command 44

Sometimes it also says that Ardour was not fast enough for Jack. Is there a problem in the configuration of Jack? latency? It’s strange because it used to work just fine, then I started getting these errors especially while recording. Any suggestion is appreciated.

Is this a bug?? I’m running AVlinux which I’ve just reinstalled. With the first installation I didn’t have any of these problems…

Maybe it’s a bug, maybe not, maybe just misconfiguration. But Pauls link should give you a hint, that you at least should have included much more information.

First it seemed you wanted to imply that this behaviour started suddenly without any obvious reason or changes. Now you stated that it happened after you reinstalled your OS!!! Is this (including all packages) still at the same verion at all? Did you install in the exact same way, including on the same harddrives and partitions? Did you change other things? Hardware? Why did you reinstall at all? Do you have a pet that might have chewed a cable? Anything else we should know…?

Ok here’s the whole story.
First installation: everything was working fine, occasionally I had some crashes, but I never got those errors. I reinstalled because the system appeared to be more unstable after updating and tweaking with themes and fonts.
Second installation: I started getting those errors. So I said, hey let’s go for another one!
Third reinstallation (which I did just today): everything works just fine, or so it seemed… The only things I modified after this installation are changing the desktop wallpaper, setting up my network connection, installing skype, mounting a drive which is dedicated to data. Now the errors and the crashes are back. All these installations come from the same ISO image, AVlinux 3.0. The partitions on which I installed the OS are the same. Maybe I mounted the data drive in a different way? Yet I tried to open a session from the main drive (i.e. the folder was created in my home) but nothing changed. Do you think all these problems derive from the subsequent reinstallations?
Thanks for your help guys

Saint Jules,

There is an updated package of Ardour for AV Linux 3.0, At the time AV3 was released there was no “Debianized” source package so AV3 has a version of Ardour built from source, this really shouldn’t be an issue but just in case for the sake of trial and error you may want to try the newer package. PLEASE NOTE, you should unpin and uninstall the existing Ardour 2.8.4avlinux package with Synaptic and you will need to manually remove the Ardour “.desktop” file from /usr/share/applications. Then install the Ardour -i686-2.8.4 deb from the link below, it will pull in several python related packages and then you should be good to go.

Find it here:

For the record AV Linux 3.0R1 is soon to be released and will address issues users have had with Xorg 7.4 and certain nVidia drivers, slow booting and spurious warnings caused by udev and will have some updated packages like Rosegarden Thorn Alpha2 , MusE 1.0, the new Jconvolver GUI from the Guitarix developers and hopefully the new FFado 2.0.

Debian unstable has not been a very hospitable distribution base lately!

Thanks for your help Gmaq, but it didn’t work, always the same errors. I’m more than frustrated right now, I thought AVlinux was the right distro for audio, but it’s been such a pain lately. Still I don’t know why everything was ok with the first installation… By the way, what do those errors mean?


Are there issues or instability with other progs or Ardour only? Are you using a MIDI Controller surface of some type because at a quick glance the errors appear to be related to MIDI Machine Control.

No I’m not using MIDI and yes, this happens with Ardour only. Well I didn’t try all the other apps, but I’m pretty sure it’s all about Ardour.

does this error happen with other sessions, or a brand new session?

In both cases…

Saint Jules,

Are you using a lot of the new Calf LV2 plugins? The version included in AV3 are from GIT and are development versions which may be unstable, On my own system they have caused some lockups when I add or remove them during playback.

Also there is a testing version of AV 3.0R1 you may want to try and see if the problems are still present, See here:

Hi, I want to say that I’m having the same issues here under Ubuntu Studio Karmic, with a fresh install of Ardour 2.8.4. The MMC errors can even cause Ardour to crash unless I disable the sync “use MMC”. I just started after I upgraded to 2.8.4 even when I was using Ubuntu Studio Jaunty…

I’ve been having the same “MMC: cannot send command” error popping up on Ardour - Log window for six months or so. I just put the log window down at the bottom of the screen and ignore it, so it’s not popping up everytime i move the playhead or tell A3 to do something. I’m using Ardour3beta5 on AV Linux 6.0. However, this MMC error also occured on previous beta releases of A3 and the previous version of AV Linux as well.

Otherwise, I’m experiencing no other problems. Just an annoying pop up window with “MMC: cannot send command.”


This is a result of Ardour 3beta5 being built with ‘Send MIDI Machine Control commands’ being enabled by default, this happens pretty commonly in SVN builds, as the developers are working and making changes occasionally certain configurations get changed by accident in the default settings. To my knowledge this also affected the bundle for beta 5.

To make that message go away simply go into Ardour 3’s Edit–>Preferences–>MIDI and deselect '‘Send MIDI Machine Control commands’

I haven’t seen this error message for quite awhile. Unfortunately, I can’t remember exactly when it stopped, but it seems like one of the Ardour updates probably fixed it. I forgot about it, but just thought I’d mention that it’s stopped (I’m going through old threads right now hehe).