Just upgraded Ubuntu, now Ardour won't launch

Ardour 8.2 has been working fine with Ubuntu 20.04.
I just upgraded to 22.04 and now it won’t launch.
I thought it wise to re-install Ardour under 22.04, so I did the usual thing and all seemed fine. (I took the option to uninstall previous versions, including 8.2, since the upgrade was “in place” and I thought it safer to re-install fully)
So I have a new .desktop file and when I double click in the file manager, I can choose between opening as text, running, or running in terminal window. Running seems to do nothing. When I run in terminal, it looks like a terminal window might be trying to open top left, but it disappears before it even gets visually established. I have “allow execution” ticked in the desktop file permissions.
Help pls!

Is this about installing the official binary from Ardour.org, if so see https://ardour.org/first_time_linux.html

try sh ~/Downloads/Ardour-8.2-x86_64.run

Or does ardour fail to start – the .desktop file hints at that.

Are you using the official binary from Download Ardour | Ardour Community, or the package from Ubuntu?

Please open a Terminal window, and if you acquired Ardour from ardour.org run


for the Ubuntu version, use a lower-case a:


There should be some output printed there which may provide some clues.

Robin, thanks for such a quick response.
I have the Ardour.org binary, not an Ubuntu-supplied one.
I ran “Ardour8”, output below, and Ardour launched. From a quick test it looks fine. Phew!
There are a couple of queries from the terminal window :-

  • Failed to load module “canberra-gtk-module”. Should I install this, and also libcanberra ?
  • Cannot xinstall SIGPIPE error handler. Should I worry about this?

So maybe it’s a problem with the desktop file and my system? I’m happy to type Ardour8 into a window to launch it, unless that’s in any way dodgy.

Here is the Terminal output -
Ardour8.2.0 (built using 8.2 and GCC version 6.3.0 20170516)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /opt/Ardour-8.2.0/etc/system_config
Ardour: [INFO]: Loading user configuration file /home/bill/.config/ardour8/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core™ i7-6700K CPU @ 4.00GHz
Ardour: [INFO]: Using AVX and FMA optimized routines
Ardour: [INFO]: Loading plugin meta data file /opt/Ardour-8.2.0/share/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin statistics file /home/bill/.config/ardour8/plugin_metadata/plugin_stats
Ardour: [INFO]: add_lrdf_data ‘/home/bill/.config/ardour8/rdf:/opt/Ardour-8.2.0/share/rdf:/usr/local/share/ladspa/rdf:/usr/share/ladspa/rdf’
Cannot xinstall SIGPIPE error handler
Ardour: [INFO]: Loading default ui configuration file /opt/Ardour-8.2.0/etc/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/bill/.config/ardour8/ui_config
Ardour: [INFO]: Loading 457 MIDI patches from /opt/Ardour-8.2.0/share/patchfiles
Gtk-Message: 17:02:10.159: Failed to load module “canberra-gtk-module”
Ardour: [INFO]: Loading colour file /opt/Ardour-8.2.0/share/themes/dark-ardour.colors
Ardour: [INFO]: Loading ui configuration file /opt/Ardour-8.2.0/etc/clearlooks.rc
start clocking
Ardour: [INFO]: Loading bindings from /opt/Ardour-8.2.0/etc/ardour.keys
Loading ui configuration file /opt/Ardour-8.2.0/etc/clearlooks.rc
Found nothing along /home/bill/.config/ardour8/templates:/opt/Ardour-8.2.0/share/templates
Set cursor set to default
start clocking
Setting time domain
start clocking