join two mono regions into one stereo track?

I’m brand new to Ardour and I’m trying to figure out how to do something that I would think would be pretty simple to accomplish. I have two mono WAV files that are simply the left and right of a stereo sample. I imported the two of them as regions into a project and want to add them as the left and right of a stereo track, but I can’t figure out how to do that! The only thing I can think to do is to add the regions to their own mono tracks, set the inputs of the stereo track to the mono tracks and hit record, but that seems extremely inelegant (and possibly lossy, I imagine).

the way you had found out is not inelegant and not lossy. You have quite some freedom by doing things this way (panning, extra effects, etc).

But is it important to have a stereo track ? you know when you export the whole session, things will end up in a stereo file anyway. It is nice to stay close to sources as much as possible :slight_smile:

So recording them to a stereo track in the way I described would be the same as if I straight copied the regions into the stereo track?

It’s important, to me, to have a stereo track because otherwise I need to have a mono track for each region. If I have the tracks set up like that, I’ll have to make sure that anytime I edit one track the same thing happens to the other track, which can be a headache – unless there’s a way to permanently link two tracks for editing…?

IMO - ardour makes working with stereo tracks a PITA. Stick to two mono tracks.

If you must, send the two tracks to the left and right input of a stereo bus

unless there’s a way to permanently link two tracks for editing…?

sure, output each mono track output to resp. left and right input of a stereo bus :slight_smile:

Apply your effects on the bus. I think you can even “link” the mono track regions together (I’m not sure on that one as I never had the need to do so) so if you move one, the other moves as well.

On import you can select the left and right files and then choose “all files in one region” from the mapping options. Note that this option is only available if multiple files are selected.

1 Like

That works perfectly C.L.A, thanks!


Heh well you are the first person I have heard report that specific issue, so it may just be noone has noticed it before to fix it, and it may be specific to Mixbus since, as I mentioned above, the original functionality may not make as much sense in Mixbus without some modification to the logic.

ah so it might be a bug in ardour 3.

I used ardour to record the stereo track. in the interchange folder was an audio left wave and nd audio right wave.

No that is most likely correct. The bug would likely be in Mixbus then on the import step.



I just tried it here; it works fine.

Select both files in the Import dialog. They must be exactly the same length, or you won’t get the “Merge” option. Choose “Add Files: As New Tracks” and “Mapping: Merge Files”.


Heh I didn’t even realize that options still existed in Mixbus, it probably shouldn’t, or should create stereo regions at most. My bet is the issue is that while it is technically possible for multichannel regions to exist, there is nothing above a stereo track in Mixbus, so the mapping to outputs gets a bit screwy to put it mildly.



I suggest you import to a “track”, not to the region list. Choose the “merge” option. Then Mixbus will create a stereo track with a stereo region for you, and you should hear the levels correctly.

I suspect you just need to drag your region onto a stereo track. Or if not, send us more details and we’ll try to get it sorted.


basically what I did was import and highlight the 2 wave files. the wave files are from a stereo track but are separate so one is left and one is right.

doing it normally created to mono tracks.

merging created 1 mono track.

I think the problem really is that I used ardour to record the track in the first place . even though I used a stereo track. ardour uses separate waves.

so on importing to mixbus it’s treated as mono tracks.

it makes sense that merging will created a mono track.


I don’t believe that is the intent however, the intent is likely to create a stereo file and a stereo track, and you likely have discovered a bug.


ah right, well i guess there are still some bugs since mixbus use ardour

im hoping mixbus v3 comes out soon

was just looking for a solution to this as i had imported the left and right waves from an ardour project into mixbus, however using “all files in one region” does not create a stereo track but seems to combined both files into a mono channel. this results in a track that is quieter than the original.