Jamtaba, Linux, Ardour

Linux, EndeabourOS (Arch-based)

I’ve downloaded the Jamtaba plugin for Linux from their site. After running the downloaded file, the installer crashes and will not launch.

As a workaround, I tried exporting the ninjam plugin reaninjam.vst.so from Reaper and importing it into Ardour. After importing it into Ardour I get an error with the message:

[Info]: Scanning: /usr/lib/vst/reaninjam.vst.so
[ERROR]: ** ERROR ** VSTFX : reaninjam.vst could not be instantiated :(

[WARNING]: Cannot get VST information from '/usr/lib/vst/reaninjam.vst.so': instantiation failed.
Scan Failed.

Does anyone here use Ardour with Jamtaba, and can advise?

The github page says VST is just for Windows:
JamTaba github
" JamTaba can be used as a standalone software, VST (Windows) or AU (Mac OSX) plugin."

" At moment JamTaba standalone works for Windows (Windows XP is not supported since v. 2.1.0), Mac OSX (10.7+) and Linux. The VST plugin is available for windows only (32 and 64 bits) and an Audio Unit (AU) plugin is available for Mac OSX users."

[emphasis in original]

Do you run Reaper on Windows? Or does Reaper include some kind of WINE based translator for running Windows VST plugins on Linux?

Without seeing the error messages from the installer my first guess would be that an Arch-based distribution is running some very latest version of a library that is not compatible with the pre-built binary. You could try building yourself from the github repository.

[edit] Actually, a little farther down the README.md at github it indicates that the binary is statically linked, so incompatible libraries would not seem to be the problem:
" We are distributing pre compiled static libs just for convenience"

So in summary, you will have to run the stand alone version on Linux, and the github project seems like the best place to look for assistance.

The github page doesn’t exactly say the VST is only for Windows. It says, “Jamtaba can be used as a standalone, or VST Windows, or AU macOS.” Then, it gives the option to download an installer for all three platforms, Windows/macOS/Linux. My assumption was that, once downloaded, the installer would give the option of using either the standalone version or the appropriate plugin version.

As I mentioned I’m running EndeavourOS but I also tried this from my Debian install and the behavior is the exact same - the installer crashes, never launches.

Within Reaper on Linux/macOs (and, I assume, Windows) there is a native plugin called reaninjam. Jamtaba is basically a prettier gui version of ninjam. So, I odn’t really need Jamtaba, it would also be fine if I could pull ninjam from Reaper and import it into Ardour, but as I wrote in my OP, that doesn’t work either…

I would be very surprised to hear that no user of Ardour has tried to run Ninjam or Jamtaba. Perhaps anyone who is doing so is simply running the Windows VST through wine, which is what I will try next.

You’re right about Jamtaba’s github being the best place to look for assistance and I"ve posted there as well. Thanks so much for your input.

Actually it does sat that the VST is Windows only(32 and 64 bit).
As quoted above, but I am giving a little more context:

So yes that VST plugin is Windows only atm.

I have used Jamtaba on Windows and Mac, but not on Linux. At this point I would probably look at Sonobus if I was to do that again honestly rather than Jamtaba/ninjam, but different tools and Sonobus is a better fit for my particular use case.


EDIT: Not sure on the exact Ninjam plugin on Reaper, but my guess is that there is missing GUI libs when it is removed from the Reaper context which is likely why it won’t instantiate correctly.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.