jackdmp says: unknown driver 'alsa'

I’ve just installed jackdmp on a ubuntu 8.04 (32bits) but when i try to run it it doesn’t recognize the alsa drivers. Which are there, and were working with jackd. Do I have to compile jackdmp again with some extra flags? Does anybody have a hint for me?
This is the output:

jorgose@ubuntulaptop:~$ jackd -d alsa --help
jackdmp 1.90
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2008 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Unkown driver “alsa”

Thanks jorgos

My guess is you don’t have the alsa-devel package installed, so when you compiled jackdmp it couldn’t link to alsa.

Install that and recompile and I’m sure it’ll work.

yes i’m the same guy, In fact i couldn’t solve that one :(, i guess i messed up things combining 32 with 64 bit libs; so i reinstalled in 32 bits so i don’t have to tweak very much to get things done. I thank you for your help!!

hey jorgose, you’re the same guy from the ubuntu forums ? So you got your system up and running ?

you are absolutely right! jackdmp runs now, thank you very much.

Hi, I have this same problem. When I look in Synaptic for the “alsa-devel” package, I don’t see anything. Where can I find this package?

you probably need a package called


libasound2 is a shared library for ALSA applications. The -dev package will allow you to compile these apps against it.

Thanks, but that did not work. Is there a specific order of operations for these things? I installed libasound2 and then reinstalled jackdmp, but no dice. Any other suggestions are appreciated.

I meant the -dev package (libasound2-dev).

Yes, sorry, libasound2-dev is what I installed.

… did you reconfigure the jack2 source tree after you installed the ALSA dev package ?

it would help to see the output of

./waf configure --prefix=/usr

we would have a chance to see something odd if any.

Hi thorgal,

Thanks again for taking the time to help me. I installed Jack2 using this ppa:


So I never had to do anything except reload Synaptic and install. When I added the libasound2-dev, all I did was add it via Synaptic, then uninstall and reinstall Jack the same way. When I run the command you suggest, I get this:

lavadisco@lavadisco-laptop:~$ ./waf configure --prefix=/usr
bash: ./waf: No such file or directory

@lava sounds like that version of Jack you installed was compiled without Alsa support. You need to either install a version of Jack with it compiled in(The VAST majority of packages out there fall under this) or build it yourself from source.


@lava: ah!! but that explains why you have a problem :slight_smile:

you never tried to compile it yourself. The -dev package only makes sense if you want to compile it yourself, which is what I thought you were trying to do.

OK, if you are not comfortable with compiling from source, get a pre-compiled version that was configured with ALSA enabled. This package you installed sounds like it was intended for non ALSA users (most likely ffado ppl).
Fetch another package with ALSA in :smiley:

I did previously have a version of Jack that worked with Alsa, but even at higher latencies (like 60 ms) I was getting this error:

subgraph starting at qjackctl timed out (subgraph_wait_fd=16, status = 0, state = Running, pollret = 0 revents = 0x0)

So I thought I’d upgrade from Jack to “Jack2” to try and fix it. I guess I have to revert. If I do so, does anybody know why I would be getting the above error?

Perhaps I should start a new thread for the original error.

Thanks Thorgal, it works for me… I instaled libasound2-dev and then
./waf uninstall
./waf configure
./waf build
sudo ./waf install

P.S. All this in jack-1.9.4 source dir which i downloaded