jack starts and ardour plays but no sound

I have tried everything i can think of.I did a ppa upgrade today and it changed hydrogen drums.9.4 to the .9.5 version which allows for tempo changes but then no sound would come.Programs like audacity and Lmms worked but not ardour nor hydrogen drums until i switched audio driver to alsa.Any one have any ideas?I really could use some help

You have not given very many details so its rather hard to reply. Sounds like you have a basic Jack/Ardour connection problem. I recommend looking at http://www.linuxjournal.com/article/8354 and http://en.flossmanuals.net/ardour/index/ .

Yea I am sorry about that.Thanks for the links,I read them and tried everything I know to dobut its not working,Ill give details and if you could help me I would appreciate it.

I use jackd and ardour to record.I use hydrogen drum which i routh thru jack into ardour.I recentely used a kxstudio ppa so i could have the .9.5 version of hydrogen which has a tempo change function which i need for my songs and after the ppa did a bunch of upgrades there was no sound when i run jackd both hydrogen and ardour run and look like they are making sound but no sound iscoming from speakers.

Any helpwould be so much appreciated.

Ahhhhh so i uninstalled jackd thinking i could reinstall it and i ended up uninstalling ardour.I finally got ardour and jackd installed but I had to go thru the terminal,it wouldn’t let me in the software center.Now my songs all sound like they are out of pitch and faster maybbe.Can someone please please help me

If the pitch is wrong, check your sample rate settings e.g. 44100, 48000 etc

yes that was the problem but im having problems with jack and ardour it was working ie. getting sound but my guitar was not making it into ardour even though i wired it thru jack.I have no idea what do to.Any help would be so so appreciated